Bug 425441 - ImageMagick woes with EXA acceleration on ATI Radeon X800
ImageMagick woes with EXA acceleration on ATI Radeon X800
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
: 425431 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 16:13 EST by Joachim Frieben
Modified: 2008-03-12 13:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 13:57:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample screenshot of corrupted ImageMagick session (766.91 KB, image/png)
2007-12-14 16:13 EST, Joachim Frieben
no flags Details
xorg.conf for ATI X800 and EXA acceleration (1013 bytes, text/plain)
2007-12-14 16:15 EST, Joachim Frieben
no flags Details
Xorg.0.log for ATI X800 and EXA acceleration (46.18 KB, text/plain)
2007-12-14 16:16 EST, Joachim Frieben
no flags Details
xorg.conf for ATI X800 and EXA acceleration [anaconda] (639 bytes, text/plain)
2007-12-14 16:22 EST, Joachim Frieben
no flags Details
Xorg.0.log for ATI X800 and EXA acceleration [anaconda] (35.69 KB, text/plain)
2007-12-14 16:24 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2007-12-14 16:13:12 EST
Description of problem:
ImageMagick's 'display' is completely unresponsive and shows empty
application windows for large images when EXA acceleration is active
for an ATI Radeon X800 card.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.195-5.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Open some large image file with ImageMagick's 'display' command.
2. Click point in window to make toolbar visible.
  
Actual results:
Toolbar appears but is empty. Random clicks inside the toolbar let
submenus appear but the application seems to be saturated. It's very
slow, unresponsive, and impossible to use. The pan window never shows
the right content, just the part of the screen where it appeared
and it doesn't get updated.

Expected results:
ImageMagick operates normally.

Additional info:
- selecting XAA acceleration allows to restore normal operation.
- this is with plain metacity - no compiz.
- no other application shows similar problems when EXA is enabled.
- Possibly an issue with xrandr which doesn't like the 1400x1050
  native mode of my HP A4576A 21" CRT anyway.
Comment 1 Joachim Frieben 2007-12-14 16:13:12 EST
Created attachment 289441 [details]
Sample screenshot of corrupted ImageMagick session
Comment 2 Joachim Frieben 2007-12-14 16:15:38 EST
Created attachment 289451 [details]
xorg.conf for ATI X800 and EXA acceleration
Comment 3 Joachim Frieben 2007-12-14 16:16:18 EST
Created attachment 289461 [details]
Xorg.0.log for ATI X800 and EXA acceleration
Comment 4 Joachim Frieben 2007-12-14 16:22:46 EST
Created attachment 289471 [details]
xorg.conf for ATI X800 and EXA acceleration [anaconda]
Comment 5 Joachim Frieben 2007-12-14 16:24:09 EST
Created attachment 289481 [details]
Xorg.0.log for ATI X800 and EXA acceleration [anaconda]

Issue still present for original xorg.conf [plus EXA option].
Comment 6 Joachim Frieben 2007-12-14 16:26:31 EST
*** Bug 425431 has been marked as a duplicate of this bug. ***
Comment 7 Joachim Frieben 2008-01-31 16:19:14 EST
Interesting: 'display' also behaves correctly when exa is enabled -and-
either compiz or the integrated metacity compositor are active.
And actually, the image size doesn't play a role as reported as my
first impression, so certainly no xrandr issue.
Comment 8 Joachim Frieben 2008-03-12 13:57:55 EDT
Issue seems to be essentially fixed at least in xorg-x11-drv-ati-6.8.0-3.fc9.

Note You need to log in before you can comment on or make changes to this bug.