Bug 425591 - HTS can only scan one CCISS disk
HTS can only scan one CCISS disk
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: YangKun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 17:35 EST by Shengliang Lv
Modified: 2007-12-18 21:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 21:30:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shengliang Lv 2007-12-14 17:35:03 EST
Description of problem:
There are three CCISS disks(c0d0, c0d1, c0d2) presented to cciss controller, 
but "hts plan" only add one cciss disk(c0d0) to test plan:

[root@max hts]# cat /proc/partitions
major minor  #blocks  name

   8     0   71687369 sda
   8     1     102400 sda1
   8     2   71584935 sda2
   8    16   71687369 sdb
 104     0  286683944 cciss/c0d0
 104    16  143338560 cciss/c0d1
 104    32  143338560 cciss/c0d2
 104    33     102400 cciss/c0d2p1
 104    34  143236126 cciss/c0d2p2

[root@max hts]# hts print

Test Plan:
----------------------------------------------------------------
usb
network    eth7       net_00_11_0a_a5_a0_1a
network    eth6       net_00_11_0a_a5_a0_19
network    eth5       net_00_11_0a_a5_a0_22
network    eth4       net_00_11_0a_a5_a0_21
network    eth3       net_00_1b_78_78_09_d3
network    eth2       net_00_1b_78_78_09_d2
network    eth1       net_00_1b_78_78_09_d1
network    eth0       net_00_1b_78_78_09_d0
memory
core
video                 pci_1002_515e
storage    sdd        storage_serial_3600508b4001086670000e0000d390000
storage    sdc        storage_serial_3600508b4001086670000e0000d320000
storage    sda        storage_serial_35000c50000d305d3
storage    sdb        storage_serial_35000c50000d4101f
storage    cciss/c0d0 pci_103c_3230
info



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 YangKun 2007-12-18 01:44:03 EST
Shengliang,

This is a planned change. For each cciss storage controller, test one "HD"(the
first one) which attached on it is enough.

Another reason is each cciss storage controller has only one entry in HAL.

Regards
-YK
Comment 4 YangKun 2007-12-18 21:30:31 EST
Shengliang,

I'm closing this as NOTABUG now since it's an intended change.

Regards
-YK

Note You need to log in before you can comment on or make changes to this bug.