Bug 425816 - libdvdnav-devel Requires:
libdvdnav-devel Requires:
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdvdnav (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-16 03:23 EST by Florian La Roche
Modified: 2008-01-16 08:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 08:02:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-12-16 03:23:29 EST
Description of problem:

libdvdread-devel is now a subrpm of libdvdnav. Please remove the
"Requires: libdvdread-devel" from the spec file and make sure that
the libdvdread library is used from the source rpm at link time.

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Florian La Roche 2008-01-06 12:31:19 EST
Hello Dominik,

any word on this? Should the old lib be remove to kept around
for some longer time?

regards,

Florian La Roche
Comment 2 Dominik 'Rathann' Mierzejewski 2008-01-06 12:41:33 EST
(In reply to comment #0)
> Description of problem:
> 
> libdvdread-devel is now a subrpm of libdvdnav. Please remove the
> "Requires: libdvdread-devel" from the spec file and make sure that
> the libdvdread library is used from the source rpm at link time.

No. libdvdnav-devel does require libdvdread-devel. I will add
%{version}-%{release} requirement instead.
Comment 3 Florian La Roche 2008-01-06 13:16:52 EST
Currently there are two binary rpms in the tree due to two different
src.rpms producing the same package names:

[laroche@dudweiler Packages]$ pwd
/home/mirror/fedora/development/i386/os/Packages
[laroche@dudweiler Packages]$ ls libdvdread-*
libdvdread-0.9.7-3.fc8.i386.rpm  libdvdread-devel-0.9.7-3.fc8.i386.rpm
libdvdread-4.1.1-3.fc9.i386.rpm  libdvdread-devel-4.1.1-3.fc9.i386.rpm
[laroche@dudweiler Packages]$

Do these overlap and one should be removed or should rpm package names
to moved to a new name?

Thanks a lot,

Florian La Roche
Comment 4 Florian La Roche 2008-01-06 13:19:11 EST
Looking at this again, the above report was not about the duplicate rpms,
but about the src.rpm depending on one of its su-rpms instead of
compiling against itself.

regards,

Florian la Roche
Comment 5 Dominik 'Rathann' Mierzejewski 2008-01-06 13:25:35 EST
If you look at the specfile you'll see that it doesn't have BuildRequires:
libdvdread-devel. It does compile against itself. In your original report, you
mentioned Requires: of the libdvdnav-devel package, not its BuildRequires:.

And yes, the older RPMs may be removed.
Comment 6 Florian La Roche 2008-01-16 08:02:38 EST
Looks all good, so closing this bz now.

Thanks a lot,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.