Bug 425873 - busybox cut command suppresses redirected output
busybox cut command suppresses redirected output
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: busybox (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On: 423011
Blocks: 399731
  Show dependency treegraph
 
Reported: 2007-12-16 20:10 EST by Neil Horman
Modified: 2008-02-28 03:51 EST (History)
1 user (show)

See Also:
Fixed In Version: busybox-1.6.1-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 03:51:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Horman 2007-12-16 20:10:48 EST
+++ This bug was initially created as a clone of Bug #423011 +++

Description of problem:
a cut command that works when output goes to the console but produces no output
otherwise

Version-Release number of selected component (if applicable):
busybox-1.2.2-8.fc7

How reproducible:
always

Steps to Reproduce:
see attached log
  
Actual results:
cut produces an empty file

Expected results:
cut produces a file with "1"

Additional info:
This seems to be why kdump is currently broken, at least for me.  See
https://bugzilla.redhat.com/show_bug.cgi?id=399731

-- Additional comment from hugh@mimosa.com on 2007-12-13 04:34 EST --
Created an attachment (id=287111)
demonstration / exploration of busybox's cut behaviour


-- Additional comment from varekova@redhat.com on 2007-12-13 11:06 EST --
This problem is fixed in busybox-1.2.2-9.fc7 which will be in test branch soon.

-- Additional comment from hugh@mimosa.com on 2007-12-14 12:37 EST --
I think that means it will appear in
http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/7/x86_64/
It's not there yet.
The busybox site lists 1.8.2 as the latest stable version. 1.2.2 dates back to
October 2006.

F8 uses 1.6.1 (2007 June) as a base.  It does not have this bug nor does it have
https://bugzilla.redhat.com/show_bug.cgi?id=423781 .  Would it be good to rebase
to 1.6.1?

-- Additional comment from updates@fedoraproject.org on 2007-12-15 12:50 EST --
busybox-1.2.2-9.fc7 has been pushed to the Fedora 7 testing repository.  If
problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update busybox'

-- Additional comment from hugh@mimosa.com on 2007-12-15 23:04 EST --
This version seems to fix the cut bug.  kdump now works.  Thanks.
Comment 1 D. Hugh Redelmeier 2007-12-16 21:21:43 EST
I tested busybox 1.6.1 on a live F8 i386 CD.  It seemed to work.  So I suspect
that the bug is in x86_64.  Of course I could have slipped up somehow.

Is this a fix that needs to be pushed upstream?
Comment 2 Ivana Varekova 2007-12-17 04:47:47 EST
Fixed in  busybox-1.6.1-3.fc8.
Comment 3 Fedora Update System 2007-12-20 15:16:34 EST
busybox-1.6.1-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update busybox'

Note You need to log in before you can comment on or make changes to this bug.