Bug 425880 - yum does not find provides for kmod / kernels
yum does not find provides for kmod / kernels
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-16 23:40 EST by Fernando Lopez-Lezcano
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 14:33:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fernando Lopez-Lezcano 2007-12-16 23:40:56 EST
Description of problem:
yum is not properly matching provides with requires for kmod and kernel
installs. This problem is new and "package-cleanup --problems" is now reporting
problems for kmod packages that have been installed previously (and have the
proper dependencies installed!). 

Version-Release number of selected component (if applicable):
yum-3.2.8-2.fc7

How reproducible:
Always. 

Installed packages (that were installed successfully) are now reported as
problems by package-cleanup. Can't install new kmod packages even though the
kernel is providing the requirements for the kmod package. 

Steps to Reproduce:
1. install a kmod package
2. install fails
3. see below for details
  
Actual results:

----
# yum --enablerepo planetstage install kmod-ipw3945-rt
Loading "fedorakmod" plugin
Loading "kernel-module" plugin
planetcore                100% |=========================| 1.9 kB    00:00     
livna                     100% |=========================| 2.1 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
planetccrma               100% |=========================| 1.9 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
planetstage               100% |=========================| 1.9 kB    00:00     
Excluding Packages from Livna for Fedora Core 7 - i386 - Base
Finished
Setting up Install Process
Parsing package install arguments
Package kmod-ipw3945-rt - 1.2.1-1.2.6.22.6_1.rt9.1.fc7.ccrma.i686 is already
installed.
Package kmod-ipw3945-rt - 1.2.2-1.2.6.23.1_1.rt11.1.fc7.ccrma.i686 is already
installed.
Package kmod-ipw3945-rt - 1.2.2-1.2.6.23.9_1.rt12.2.fc7.ccrma.i686 is already
installed.
Package kmod-ipw3945-rt - 1.2.2-1.2.6.22.9_1.rt9.1.fc7.ccrma.i686 is already
installed.
Package kmod-ipw3945-rt - 1.2.2-1.2.6.22.10_1.rt9.1.fc7.ccrma.i686 is already
installed.
Package kmod-ipw3945-rt - 1.2.1-1.2.6.22.6_1.rt9.3.fc7.ccrma.i686 is already
installed.
Package kmod-ipw3945-rt - 1.2.2-1.2.6.22.6_1.rt9.5.fc7.ccrma.i686 is already
installed.
Package kmod-ipw3945-rt - 1.2.2-1.2.6.23.9_1.rt11.1.fc7.ccrma.i686 is already
installed.
Resolving Dependencies
--> Running transaction check
---> Package kmod-ipw3945-rt.i686 0:1.2.2-1.2.6.23.9_1.rt12.1.fc7.ccrma set to
be installed
--> Processing Dependency: kernel-i686 = 2.6.23.9-1.rt12.1.fc7.ccrmart for
package: kmod-ipw3945-rt
---> Package kmod-ipw3945-rt.i686 0:1.2.2-1.2.6.23.9_1.rt13.1.fc7.ccrma set to
be installed
--> Processing Dependency: kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart for
package: kmod-ipw3945-rt
--> Running transaction check
---> Package kmod-ipw3945-rt.i686 0:1.2.2-1.2.6.23.9_1.rt13.1.fc7.ccrma set to
be installed
--> Processing Dependency: kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart for
package: kmod-ipw3945-rt
---> Package kernel-rt.i686 0:2.6.23.9-1.rt12.1.fc7.ccrma set to be installed
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart is needed
by package kmod-ipw3945-rt
----

So there seems to be a missing dependency.
Not really:

----
# rpm -q --provides kernel-rt-2.6.23.9-1.rt13.1.fc7.ccrma
kernel = 2.6.23.9
kernel = 2.6.23.9-1.rt13.1.fc7.ccrma
kernel-drm = 4.3.0
kernel-drm-nouveau = 10
kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart
kernel-rt = 2.6.23.9-1.rt13.1.fc7.ccrma
----

This is the "missing dependency":
kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart

This is the matching provides line for the installed kernel:
kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart

They match. But yum does not agree and will not let the kmod package install to
happen. 

Expected results:
Kmod kernel module installs successfully, as has been happening till the last (I
think) yum upgrade. 

Additional info:
Comment 1 Seth Vidal 2007-12-16 23:56:18 EST
You've got both the kmod and the kernelmodule plugins installed? Can you try the
above with:

1. kmod disabled
2. kernel-module disabled
3. both disabled

thanks
Comment 2 Fernando Lopez-Lezcano 2007-12-16 23:58:31 EST
(In reply to comment #0)
> Description of problem:
> yum is not properly matching provides with requires for kmod and kernel
> installs. This problem is new and "package-cleanup --problems" is now reporting
> problems for kmod packages that have been installed previously (and have the
> proper dependencies installed!). 

Arghhh, looks like an rpm problem??

After manually downloading the package rpm itself refuses to install it:

----
# rpm -ivh kmod-ipw3945-rt-1.2.2-1.2.6.23.9_1.rt13.1.fc7.ccrma.i686.rpm 
error: Failed dependencies:
        kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart is needed by
kmod-ipw3945-rt-1.2.2-1.2.6.23.9_1.rt13.1.fc7.ccrma.i686
----

Again:

----
# rpm -q --provides kernel-rt-2.6.23.9-1.rt13.1.fc7.ccrma
kernel = 2.6.23.9
kernel = 2.6.23.9-1.rt13.1.fc7.ccrma
kernel-drm = 4.3.0
kernel-drm-nouveau = 10
kernel-i686 = 2.6.23.9-1.rt13.1.fc7.ccrmart
kernel-rt = 2.6.23.9-1.rt13.1.fc7.ccrma
----

What am I doing wrong??
Comment 3 Fernando Lopez-Lezcano 2007-12-16 23:59:54 EST
(In reply to comment #1)
> You've got both the kmod and the kernelmodule plugins installed? Can you try the
> above with:
> 
> 1. kmod disabled
> 2. kernel-module disabled
> 3. both disabled

The problem happened originally with both kmod and kernel-module not installed.
I installed them with the hope that that was what I was missing (ie: new
behavior that required the new plugins)...
Comment 4 Fernando Lopez-Lezcano 2007-12-17 00:04:49 EST
(In reply to comment #3)
> (In reply to comment #1)
> > You've got both the kmod and the kernelmodule plugins installed? Can you try the
> > above with:
> > 
> > 1. kmod disabled
> > 2. kernel-module disabled
> > 3. both disabled
> 
> The problem happened originally with both kmod and kernel-module not installed.
> I installed them with the hope that that was what I was missing (ie: new
> behavior that required the new plugins)...

This is the last successfull install of a kmod (from "rpm -q -a --last|grep kmod): 

kmod-ipw3945-rt-1.2.2-1.2.6.23.9_1.rt12.2.fc7.ccrma Wed 05 Dec 2007 02:10:02 PM PST

Something changed after this that broke the dependency resolution process (I did
not change anything - I think - in the kmod build process). 

Here's what package-cleanup is reporting now (remember, all these kmod packages
installed successfully):

----
# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.23.1-1.rt11.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.6-1.rt9.4.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.6-1.rt9.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.6-1.rt9.2.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.6-1.rt9.3.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.23.1-1.rt11.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.6-1.rt9.3.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.10-1.rt9.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.10-1.rt9.1.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.5-1.rt9.2.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.23.9-1.rt11.1.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.23.9-1.rt12.2.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.9-1.rt9.1.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.9-1.rt9.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.5-1.rt9.2.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.6-1.rt9.2.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.6-1.rt9.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.23.9-1.rt11.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.5-1.rt9.1.fc7.ccrmart
Package kmod-alsa-rt requires kernel-i686 = 2.6.22.6-1.rt9.5.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.6-1.rt9.4.fc7.ccrmart
Package kmod-ipw3945-rt requires kernel-i686 = 2.6.22.6-1.rt9.5.fc7.ccrmart
----
Comment 5 Fernando Lopez-Lezcano 2007-12-17 00:10:25 EST
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > You've got both the kmod and the kernelmodule plugins installed? Can you
try the
> > > above with:
> > > 
> > > 1. kmod disabled
> > > 2. kernel-module disabled
> > > 3. both disabled
> > 
> > The problem happened originally with both kmod and kernel-module not installed.
> > I installed them with the hope that that was what I was missing (ie: new
> > behavior that required the new plugins)...
> 
> This is the last successfull install of a kmod (from "rpm -q -a --last|grep
kmod): 
> 
> kmod-ipw3945-rt-1.2.2-1.2.6.23.9_1.rt12.2.fc7.ccrma Wed 05 Dec 2007 02:10:02
PM PST

More weirdness, rpm itself does not list the installed kernel-rt packages!:

----
# rpm -q kernel-rt
package kernel-rt is not installed
----

Which is obviously not true:

----
# rpm -q -a |grep kernel-rt|grep -v devel
kernel-rt-2.6.23.9-1.rt11.1.fc7.ccrma
kernel-rt-2.6.22.6-1.rt9.3.fc7.ccrma
kernel-rt-2.6.22.10-1.rt9.1.fc7.ccrma
kernel-rt-2.6.22.6-1.rt9.5.fc7.ccrma
kernel-rt-2.6.22.9-1.rt9.1.fc7.ccrma
kernel-rt-2.6.23.9-1.rt12.2.fc7.ccrma
kernel-rt-2.6.23.9-1.rt13.1.fc7.ccrma
kernel-rt-2.6.22.6-1.rt9.4.fc7.ccrma
kernel-rt-2.6.23.1-1.rt11.1.fc7.ccrma
----

Something is apparently radically different in rpm!
But the last rpm install date is:

Install Date: Fri 26 Oct 2007 03:00:26 PM PDT 

(from rpm -q -i rpm)
And I did install kmods on Dec 5...
Comment 6 Fernando Lopez-Lezcano 2007-12-17 00:13:21 EST
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > You've got both the kmod and the kernelmodule plugins installed? Can you
try the
> > > above with:
> > > 
> > > 1. kmod disabled
> > > 2. kernel-module disabled
> > > 3. both disabled
> > 
> > The problem happened originally with both kmod and kernel-module not installed.
> > I installed them with the hope that that was what I was missing (ie: new
> > behavior that required the new plugins)...
> 
> This is the last successfull install of a kmod (from "rpm -q -a --last|grep
kmod): 
> 
> kmod-ipw3945-rt-1.2.2-1.2.6.23.9_1.rt12.2.fc7.ccrma Wed 05 Dec 2007 02:10:02
PM PST

More weirdness, rpm itself does not list the installed kernel-rt packages!:

----
# rpm -q kernel-rt
package kernel-rt is not installed
----

Which is obviously not true:

----
# rpm -q -a |grep kernel-rt|grep -v devel
kernel-rt-2.6.23.9-1.rt11.1.fc7.ccrma
kernel-rt-2.6.22.6-1.rt9.3.fc7.ccrma
kernel-rt-2.6.22.10-1.rt9.1.fc7.ccrma
kernel-rt-2.6.22.6-1.rt9.5.fc7.ccrma
kernel-rt-2.6.22.9-1.rt9.1.fc7.ccrma
kernel-rt-2.6.23.9-1.rt12.2.fc7.ccrma
kernel-rt-2.6.23.9-1.rt13.1.fc7.ccrma
kernel-rt-2.6.22.6-1.rt9.4.fc7.ccrma
kernel-rt-2.6.23.1-1.rt11.1.fc7.ccrma
----

Something is apparently radically different in rpm!
But the last rpm install date is:

Install Date: Fri 26 Oct 2007 03:00:26 PM PDT 

(from rpm -q -i rpm)
And I did install kmods on Dec 5...
Comment 7 Fernando Lopez-Lezcano 2007-12-17 14:20:00 EST
(In reply to comment #6)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > (In reply to comment #1)
> > > > You've got both the kmod and the kernelmodule plugins installed? Can you
> try the
> > > > above with:
> > > > 
> > > > 1. kmod disabled
> > > > 2. kernel-module disabled
> > > > 3. both disabled
> > > 
> > > The problem happened originally with both kmod and kernel-module not
installed.
> > > I installed them with the hope that that was what I was missing (ie: new
> > > behavior that required the new plugins)...
> > 
> > This is the last successfull install of a kmod (from "rpm -q -a --last|grep
> kmod): 
> > 
> > kmod-ipw3945-rt-1.2.2-1.2.6.23.9_1.rt12.2.fc7.ccrma Wed 05 Dec 2007 02:10:02
> PM PST
> 
> More weirdness, rpm itself does not list the installed kernel-rt packages!:
> 
> ----
> # rpm -q kernel-rt
> package kernel-rt is not installed
> ----
> 
> Which is obviously not true:
> 
> ----
> # rpm -q -a |grep kernel-rt|grep -v devel
> kernel-rt-2.6.23.9-1.rt11.1.fc7.ccrma
> kernel-rt-2.6.22.6-1.rt9.3.fc7.ccrma
> kernel-rt-2.6.22.10-1.rt9.1.fc7.ccrma
> kernel-rt-2.6.22.6-1.rt9.5.fc7.ccrma
> kernel-rt-2.6.22.9-1.rt9.1.fc7.ccrma
> kernel-rt-2.6.23.9-1.rt12.2.fc7.ccrma
> kernel-rt-2.6.23.9-1.rt13.1.fc7.ccrma
> kernel-rt-2.6.22.6-1.rt9.4.fc7.ccrma
> kernel-rt-2.6.23.1-1.rt11.1.fc7.ccrma
> ----

I tested on another f7 system and could not reproduce the problem. 

Sigh, apparently a corrupted rpm database. 
Doing an rpm --rebuilddb seems to have fixed this issue. 
I have no idea how it got to that state...
Comment 8 Seth Vidal 2007-12-17 14:33:46 EST
okay, unless you mind, I'm going to close this notabug.

Note You need to log in before you can comment on or make changes to this bug.