Bug 426000 - diskdumpctl: failed to add $device
diskdumpctl: failed to add $device
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: diskdumputils (Show other bugs)
4.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Takao Indoh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 12:44 EST by Reiner Rottmann
Modified: 2013-08-05 23:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 12:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reiner Rottmann 2007-12-17 12:44:42 EST
Description of problem:
diskdump was configured according /usr/share/doc/diskdumputils-1.4.1/README and
http://www.redhatmagazine.com/2007/08/15/a-quick-overview-of-linux-kernel-crash-dump-analysis/

Not so difficult after all :-) 
# cat /etc/sysconfig/diskdump | grep -v \#
DEVICE=/dev/sdc2

However "service diskdump start" fails:

# service diskdump start
Starting diskdump:                                         [FAILED]

Even with manual intervention:

# diskdumpctl /dev/sdc2
diskdumpctl: failed to add /dev/sdc2!

I have also tried:

# mkswap /dev/sdc2
# swapon /dev/sdc2
# service diskdump start

To verify if it works without formating it the first time.

I also tried various storage systems and devices with and without additional
partitions.

Version-Release number of selected component (if applicable):
# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 4)

# uname -a
Linux hostname 2.6.9-67.ELsmp #1 SMP Wed Nov 7 13:56:44 EST 2007 x86_64 x86_64
x86_64 GNU/Linux

# rpm -qa | grep diskdump
diskdumputils-1.4.1-2

But also tested with other RHEL versions without success (e. g. RHEL 4 U5 ->
same effect).

How reproducible:
Always and on more than 4 different machines/storage systems.

Steps to Reproduce:
1. configure /etc/sysconfig/diskdump (adding DEVICE=/dev/sdc2)
(2. service diskdump initialformat)
3. service diskdump start
  
Actual results:
Starting diskdump:                                         [FAILED]

Expected results:
Starting diskdump:                                         [  OK  ]

Additional info:
We need to configure diskdump urgently because we need core dumps to further
investigate another issue.
Comment 1 Takao Indoh 2011-09-13 12:36:19 EDT
I cannot reproduce this, so I close this bz. Please reopen if this problem is  reproduced.

Note You need to log in before you can comment on or make changes to this bug.