Bug 426004 - /etc/cron.d has permissions 700 - readable/executable only by root
/etc/cron.d has permissions 700 - readable/executable only by root
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 13:18 EST by Need Real Name
Modified: 2008-11-25 19:16 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.2-8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:06:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-17 13:18:31 EST
Description of problem:
Not sure what the advantage is of hiding this directory from non-root users and
requiring root privileges just to see the names of the files added to the crontab.

Shouldn't this have perm 755 like cron.monthly, cron.weekly, cron.daily, etc.?

Are there any secrets we are trying to hide here from non-root users?
Comment 1 Need Real Name 2008-01-01 02:31:07 EST
Anybody following this bug?
It really is a PITA to have /etc/cron.d hidden.
It means I need to sudo/su just to check what are the cron programs being run.

Please either explain rationale for this non-standard perm or correct.
Either should be easy and quick allowing closure of this bug

Thanks
Comment 2 Need Real Name 2008-01-15 14:11:14 EST
Anybody following this bug? If so any reason not to fix since fix is soooo easy?
Comment 3 Marcela Mašláňová 2008-01-16 03:51:42 EST
You're right, but I'd rather fix more bugs in one update.
Comment 4 Fedora Update System 2008-02-13 02:31:18 EST
vixie-cron-4.2-8.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-02-15 21:06:08 EST
vixie-cron-4.2-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.