Bug 426017 - Anaconda. An unhandled exception occured during post-installation procedure
Anaconda. An unhandled exception occured during post-installation procedure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 14:48 EST by cyrill
Modified: 2008-03-22 13:03 EDT (History)
0 users

See Also:
Fixed In Version: 11.4.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 15:19:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (15.82 KB, text/plain)
2007-12-17 14:48 EST, cyrill
no flags Details
anaconda dump (38.44 KB, text/plain)
2007-12-17 14:49 EST, cyrill
no flags Details
my cpuinfo (1.30 KB, text/plain)
2007-12-17 14:51 EST, cyrill
no flags Details
Anaconda installation exception (49.03 KB, text/plain)
2008-03-22 13:03 EDT, Alan
no flags Details

  None (edit)
Description cyrill 2007-12-17 14:48:19 EST
Description of problem:
Anaconda caused an unhandled exception during post-installation procedure

Version-Release number of selected component (if applicable):
Fedora Core 8 LiveCD KDE x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Start inst. procedure.
2. Select custom disk layout.
3. Click next ;)
  
Actual results:


Expected results:


Additional info:
I've booted even with nodmraid param, turned off SELinux. Nothing helped.
Comment 1 cyrill 2007-12-17 14:48:19 EST
Created attachment 289799 [details]
Anaconda log
Comment 2 cyrill 2007-12-17 14:49:07 EST
Created attachment 289800 [details]
anaconda dump
Comment 3 cyrill 2007-12-17 14:49:58 EST
It happens on my Asus G2 laptop already for two days long
Comment 4 cyrill 2007-12-17 14:51:27 EST
Created attachment 289801 [details]
my cpuinfo
Comment 5 cyrill 2007-12-17 14:52:24 EST
Btw I had turned my swap off before started to install
Comment 6 cyrill 2007-12-17 14:54:46 EST
My disk layout
Command (m for help): p

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x141ea6f1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         125     1004031   83  Linux
/dev/sda2             126       18362   146488702+   5  Extended
/dev/sda3           18363       24321    47865667+  83  Linux
/dev/sda5             126         734     4891761   83  Linux
/dev/sda6             735        6814    48837568+  83  Linux
/dev/sda7            6815       14110    58605088+  83  Linux
/dev/sda8           14111       15327     9775521   83  Linux
/dev/sda9           15328       16543     9765625+  83  Linux
/dev/sda10          16543       17759     9769351+  83  Linux
/dev/sda11          17760       18362     4843566   83  Linux

i reformat these partitions to ext3 every time i'm trying to install fedora

Any suggestions are quite  welcome ;)
Comment 7 Chris Lumens 2007-12-17 15:19:08 EST
This is fixed in later builds of anaconda.
Comment 8 cyrill 2007-12-18 02:27:51 EST
So could you please a bit guide me what to do? (my prev linux experience is 
gentoo based and i never ever worked with yum).
Comment 9 cyrill 2007-12-18 03:43:28 EST
I mean when I've loaded with FC8-KDE-LiveCD what to type to upgrade anaconda 
to be able to install FC8 without problem?
Comment 10 cyrill 2007-12-18 10:52:07 EST
In reply to comment #7)
> This is fixed in later builds of anaconda.

I mean when I've loaded with FC8-KDE-LiveCD what to type to upgrade anaconda 
to be able to install FC8 without problem? Thanks
Comment 11 cyrill 2007-12-18 11:22:24 EST
it seems I found how to do it... trying to update...
Comment 12 cyrill 2007-12-18 12:05:32 EST
well, it didn't help. now anaconda fails on trying to write bootloader. I 
didn't get crash log but i do remember it failed on attempt to unlink file... 
will try to reproduce.
Comment 13 Alan 2008-03-22 12:11:18 EDT
If the issue is resolved, it doesn't seem to be available. I experienced the
exception while installing from Fedora-8-Live-x86_64 image downloaded
03-11-2008. I checked the current version:

[root@localhost ~]# su -c 'yum list anaconda'
fedora                    100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 5.8 MB    01:06     
updates                   100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 2.5 MB    00:28     
Installed Packages
anaconda.x86_64                          11.3.0.50-2            installed  

Then I tried to update it:

[root@localhost ~]# su -c 'yum update anaconda.x86_64'
fedora                    100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
Setting up Update Process
Could not find update match for anaconda.x86_64
No Packages marked for Update
Comment 14 Alan 2008-03-22 13:03:58 EDT
Created attachment 298848 [details]
Anaconda installation exception

I can think of 100 things I'd rather be spending my nights and weekends doing
than trying to get an operating system installed.

Note You need to log in before you can comment on or make changes to this bug.