Bug 426062 - multiple mounts doesn't work for local devices
multiple mounts doesn't work for local devices
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.6
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 22:23 EST by Akira TAGOH
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 04:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2007-12-17 22:23:04 EST
Description of problem:
When I have multiple mounts from the program map, mount just failed.

Version-Release number of selected component (if applicable):
5.0.1-0.rc2.55.el5.1

How reproducible:
always

Steps to Reproduce:
1.have any program map that returns multiple mount entries for local devices.
2.
3.
  
Actual results:
mount failed.

Expected results:
should mount them properly

Additional info:
autofs doesn't strip off a colon from the beginning of the path, which means the
local device, and come across to mount command as is. so it becomes "No such
file or directory" error. this is the root cause of this problem.
Comment 1 Ian Kent 2007-12-17 23:38:09 EST
(In reply to comment #0)
> Additional info:
> autofs doesn't strip off a colon from the beginning of the path, which means the
> local device, and come across to mount command as is. so it becomes "No such
> file or directory" error. this is the root cause of this problem.

Please post an example of the map used and a debug log
of the failure.

See http://people.redaht.com/jmoyer for details.

Ian
Comment 2 Akira TAGOH 2008-03-27 04:33:20 EDT
Sorry for a long delay. it was happened on rhel4 box actually and -232 works
fine for that issue. but not -231 which was shipped for 4.6.

Note You need to log in before you can comment on or make changes to this bug.