Bug 426075 - Database transaction failure causes crash
Summary: Database transaction failure causes crash
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-18 08:53 UTC by Bjorge Solli
Modified: 2008-07-09 02:52 UTC (History)
0 users

Fixed In Version: 1.4.16b-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 02:52:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from gdb (9.63 KB, text/plain)
2008-01-03 09:49 UTC, Bjorge Solli
no flags Details

Description Bjorge Solli 2007-12-18 08:53:54 UTC
Description of problem:
$ liferea
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files

** (liferea-bin:30919): WARNING **: Transaction end failed (database is locked)
SQL: END

** ERROR **: file db.c: line 618 (db_init): assertion failed:
(sqlite3_get_autocommit (db))
aborting...

Version-Release number of selected component (if applicable):
liferea-1.4.9-1.fc8
dbus-1.1.2-7.fc8
sqlite-3.4.2-3.fc8

How reproducible:


Steps to Reproduce:
1. install
2. start
  
Actual results:
crash

Expected results:
start of liferea

Additional info:
tried both on i386 and x86_64 with two different users. One that had never used
liferea before. Tried to remove dot-files.

Comment 1 Bjorge Solli 2007-12-19 10:12:24 UTC
This also happens on Fedora 7!

Comment 2 Bjorge Solli 2008-01-02 16:39:11 UTC
Any news here? I would prefer not to have to change to a different reader.

Comment 3 Brian Pepple 2008-01-02 16:59:25 UTC
(In reply to comment #2)
> Any news here? I would prefer not to have to change to a different reader.

No, I haven't had a chance to look at this bug very closely.  Based on what
you've pasted it looks like the database is getting locked-up, but it would help
if you could provide a backtrace since I'm not sure I can reproduce this bug
locally.

http://fedoraproject.org/wiki/StackTraces


Comment 4 Bjorge Solli 2008-01-02 17:24:09 UTC
That seems to be difficult as gdb reports:
"/usr/bin/liferea": not in executable format: File format not recognized

$ ls -l /usr/bin/liferea
-rwxr-xr-x 1 root root 794 2007-12-02 18:18 /usr/bin/liferea
$ head -1 /usr/bin/liferea
#!/bin/sh

I doubt this is a problem on my machine, as I can reproduce this on several
other machines (using the same network user).

I can give you my .liferea*-files, but will prefer not to give it to everyone.

Comment 5 Brian Pepple 2008-01-02 20:40:14 UTC
(In reply to comment #4)
> That seems to be difficult as gdb reports:
> "/usr/bin/liferea": not in executable format: File format not recognized

Yeah, I totally forgot it uses a script to set the firefox library path.

okay try this (I'm assuming you've got an x86 machine):

Open up a terminal and type 'export LD_LIBRARY_PATH=/usr/lib/firefox-2.0.0.10'.
Then run 'gdb liferea-bin'




Comment 6 Bjorge Solli 2008-01-03 09:49:23 UTC
Created attachment 290722 [details]
output from gdb

Output attached.

Comment 7 Bjorge Solli 2008-01-03 09:50:25 UTC
(it is 64-bit, but I get the same error on 32-bit)

Comment 8 Marc Wiriadisastra 2008-02-21 10:18:19 UTC
Does this still happen?

Comment 9 Bjorge Solli 2008-02-21 10:47:05 UTC
no, not with 1.4.11.

But there are still errors:
$ liferea
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files

** (liferea:26647): WARNING **: Could not save update state for subscription
wocakvt (error code 11)!

(this last one comes when I close it down and it repeats and hangs, so I have to
kill it).

When I do a ctr+c this comes:
(liferea:26647): Gtk-CRITICAL **: gtk_style_detach: assertion
`style->attach_count > 0' failed

Comment 10 Marc Wiriadisastra 2008-02-23 08:41:55 UTC
I can't reproduce this error.  Can you remove your ~/.liferea_1.4/ and remove
and reinstall liferea and try to reproduce it.

Comment 11 Bjorge Solli 2008-02-26 13:11:18 UTC
Done. removed the dir, unistalled the rpm, installed the rpm (using yum), and
it's reproducible:


$ rm -rf .liferea_1.4/
$ liferea
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files

(liferea:28968): Gtk-CRITICAL **: gtk_style_detach: assertion
`style->attach_count > 0' failed

Comment 12 Marc Wiriadisastra 2008-02-26 21:45:11 UTC
Run it using the menu and tell me what happens. There is always going to be
output from the console.



Comment 13 Bjorge Solli 2008-02-27 07:39:54 UTC
The same thing happens. I run it, it runs fine, but when I shut it down (using
the X-button on the window) it closes the window but the process remains
(visible using 'ps'). I had to kill it using 'kill'. I do not need to delete
.liferea_1.4 to reproduce this.

Hm.. tested using the menu->quit, and this does not produce the hang. The error
seems to be in the handling of the gnome shutdown signal from the window's X-button.

As to your comment on output to the console; There should *never* be any output
to the console, especially something saying CRITICAL! This will only lead to the
same conclusion as I have; use a different reader..

Comment 14 Fedora Update System 2008-07-09 02:52:13 UTC
liferea-1.4.16b-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.