Bug 426078 - Xerox Phaser 3117 is not correctly configured
Xerox Phaser 3117 is not correctly configured
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 04:04 EST by Ozan Çağlayan
Modified: 2008-01-17 04:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 04:45:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ozan Çağlayan 2007-12-18 04:04:14 EST
Description of problem:

I plugged in a Xerox Phaser 3117 printer. Here's the detection process logged by
syslog:
Dec 18 09:58:45 localhost hal_lpadmin: Device ID: MFG:Xerox;MDL:Phaser
3117;DES:;CMD:GDI; URI:usb://Xerox/Phaser%203117

Dec 18 09:58:46 localhost hal_lpadmin: PPD:
foomatic-db-ppds/Lanier/PS/Lanier-LP025_LP026_PS.ppd.gz; Status: 3

system-config-printer choosed Lanier-LP025 driver with a recognition status
3(NO_DRIVER).

If the ppd for Samsung ML-6040 is used instead of this Lanier, the printer works
perfectly. Here's the related openprinting.org entry:
http://openprinting.org/show_printer.cgi?recnum=Xerox-Phaser_3117

Version-Release number of selected component (if applicable):
system-config-printer 0.7.78
hal-cups-utils 0.6.13 (svn86)
Comment 1 Tim Waugh 2008-01-16 11:52:50 EST
Changing component to rawhide.

Um, it looks like you are not using our RPMs at all.  What does this say?:

rpm -q cups
rpm -V cups

Most likely you do not have a 'textonly.ppd' available, nor a 'postscript.ppd'.
 There really isn't anything sensible we can do in that case.
Comment 2 Ozan Çağlayan 2008-01-16 15:06:03 EST
Actually, I'm integrating the automatic printer detection process that you
developed into a Turkish Linux distribution called Pardus[0]. I'm gonna check if
I'm missing those ppd's.

Thanks for your reply.

[0] : http://www.pardus.org.tr/eng
Comment 3 Tim Waugh 2008-01-17 04:45:24 EST
OK.  Closing as this is not a Fedora bug (please ask future integration
questions in private mail instead).

Note You need to log in before you can comment on or make changes to this bug.