Bug 426246 - Add/Remove Software failed
Add/Remove Software failed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 426845 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 10:48 EST by John Brown
Modified: 2008-05-28 15:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 15:25:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add/Remove Software failed (1.63 KB, application/octet-stream)
2007-12-26 17:50 EST, Gudino Zahir
no flags Details

  None (edit)
Description John Brown 2007-12-19 10:48:19 EST
Following error message generated

Component: pirut
Summary: TB7bcc1c48 config.py:707:_getsysver:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 476, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 63, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 132, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 116, in
doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 162, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 640, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot,
startupconf.distroverpkg)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 707, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x945d94c>
distroverpkg: redhat-release
Comment 1 Jeremy Katz 2007-12-19 11:48:12 EST
What is the output of 'rpm -q --whatprovides redhat-release'?
Comment 2 John Brown 2007-12-24 09:16:23 EST
[john@localhost ~]$ rpm -q --whatprovides redhat-release
fedora-release-8-5
[john@localhost ~]$ 
Comment 3 Jeremy Katz 2007-12-26 13:57:51 EST
And does this happen reliably?
Comment 4 Gudino Zahir 2007-12-26 17:50:03 EST
Created attachment 290429 [details]
Add/Remove Software failed
Comment 5 Gudino Zahir 2007-12-26 17:55:52 EST
Comment on attachment 290429 [details]
Add/Remove Software failed

I've read some info about the issue and for a sec  i thought i was done because
of Yum, not sure sine i am not a linux pro, but that was my guess. now i have
to tell something and probably this can be the root of the issue. i had enable
YUM as the nornal method. now i do add some entry to the
/etc/yum/pluginconf.d/priorities.conf
i nano edit that and added 'check_obsoletes = 1'

so well i will wait for any fix for this since i am a really noob yet in linux,
but i do really want to learn more..
thanks for any reply, i sure appriciate those with all my heart
Comment 6 Jeremy Katz 2007-12-26 20:06:54 EST
Gudino -- you are seeing a separate issue (bug 421961)
Comment 7 John Brown 2007-12-27 10:40:33 EST
(In reply to comment #2)
> [john@localhost ~]$ rpm -q --whatprovides redhat-release
> fedora-release-8-5
> [john@localhost ~]$ 
> 

[john@localhost ~]$ rpm -q --whatprovides redhat-release
fedora-release-8-5
[john@localhost ~]$ rpm -q --whatprovides redhat-release
fedora-release-8-5
[john@localhost ~]$ rpm -q --whatprovides redhat-release
fedora-release-8-5
[john@localhost ~]$ 

 it would appear to be a reliable response
Comment 8 John Brown 2007-12-27 10:51:14 EST
Just retryed and received following error message:

Component: pirut
Summary: TBe0876e9f __init__.py:421:simpleDBInstalled:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 410, in
_groupSelected
    self.__setGroupDescription(grp)
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 427, in
__setGroupDescription
    if self.ayum.isPackageInstalled(p):
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 439, in
isPackageInstalled
    installed = self.simpleDBInstalled(name)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 421, in
simpleDBInstalled
    mi = self.ts.ts.dbMatch('name', name)
TypeError: rpmdb open failed

Local variables in innermost frame:
self: <__main__.PackageManager object at 0xa5b068c>
arch: None
name: tomboy
Comment 9 John Brown 2007-12-27 12:19:46 EST
Following a reboot, retrieving update information icon appeared. On selecting
Apply updates, following unhandled exception error message appeared. Could this
be part of the same problem? 
Component: pirut
Summary: TB7bcc1c48 config.py:707:_getsysver:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 603, in main
    pup = PackageUpdater(not options.autoapply, options.config)
  File "/usr/sbin/pup", line 80, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 132, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 116, in
doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 162, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 640, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot,
startupconf.distroverpkg)
  File "/usr/lib/python2.5/site-packages/yum/config.py", line 707, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0xa60b48c>
distroverpkg: redhat-release
Comment 10 richard horobin 2007-12-31 20:29:08 EST
I've had this error for over a week, and I have tried several of the suggested
solutions, with no success.

Since pirut fails, what is the "manual" work-around?  Can I use some sort of
apt-get or rpm command to bypass pirut?
Comment 11 richard horobin 2007-12-31 20:32:19 EST
Surely this group (255341, 426246, 426894) are all from the same root cause?
Comment 12 John Brown 2008-02-12 09:33:19 EST
Any movement on resolving this issue?
Comment 13 Jeremy Katz 2008-05-28 15:25:28 EDT
This should be fixed with the update which will be going out in the next week or so.
Comment 14 Jeremy Katz 2008-05-28 15:25:51 EDT
*** Bug 426845 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.