Bug 426253 - console-kit-daemon segfaults often
console-kit-daemon segfaults often
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
8
i686 Linux
high Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 11:27 EST by Dominik 'Rathann' Mierzejewski
Modified: 2013-03-05 22:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 08:44:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console-kit-daemon crash trace (4.42 KB, text/plain)
2007-12-19 11:27 EST, Dominik 'Rathann' Mierzejewski
no flags Details

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2007-12-19 11:27:21 EST
Description of problem:
I'm getting frequent crashes in console-kit-daemon. It happens when someone
tries to login via gdm. I'm not sure this problem is limited to ConsoleKit only.
I managed to catch the crash twice using gdb. Backtraces attached.

Version-Release number of selected component (if applicable):
ConsoleKit-0.2.3-1.fc8

How reproducible:
Frequently

Steps to Reproduce:
1. Configure user authentication via LDAP/TLS
2. Start gdm
3. Try to login
  
Actual results:
Dec 19 16:37:28 ws-ljw console-kit-daemon[3111]: GLib-CRITICAL:
g_async_queue_push: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:37:28 ws-ljw console-kit-daemon[3111]: GLib-CRITICAL:
g_async_queue_lock: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:37:28 ws-ljw console-kit-daemon[3111]: GLib-CRITICAL:
g_async_queue_length_unlocked: assertion `g_atomic_int_get (&queue->ref_count) >
0' failed
Dec 19 16:37:28 ws-ljw console-kit-daemon[3111]: GLib-CRITICAL:
g_async_queue_unlock: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:37:55 ws-ljw console-kit-daemon[3299]: GLib-CRITICAL:
g_async_queue_push: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:37:55 ws-ljw console-kit-daemon[3299]: GLib-CRITICAL:
g_async_queue_lock: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:37:55 ws-ljw console-kit-daemon[3299]: GLib-CRITICAL:
g_async_queue_length_unlocked: assertion `g_atomic_int_get (&queue->ref_count) >
0' failed
Dec 19 16:37:55 ws-ljw console-kit-daemon[3299]: GLib-CRITICAL:
g_async_queue_unlock: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:38:43 ws-ljw kernel: console-kit-dae[3300]: segfault at 0000000c eip
00d5dc4e esp b7fea310 error 4
...
Dec 19 16:46:56 ws-ljw console-kit-daemon[4255]: GLib-CRITICAL:
g_async_queue_push: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:46:56 ws-ljw console-kit-daemon[4255]: GLib-CRITICAL:
g_async_queue_lock: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:46:56 ws-ljw console-kit-daemon[4255]: GLib-CRITICAL:
g_async_queue_length_unlocked: assertion `g_atomic_int_get (&queue->ref_count) >
0' failed
Dec 19 16:47:14 ws-ljw console-kit-daemon[4255]: GLib-CRITICAL:
g_async_queue_push: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:47:16 ws-ljw console-kit-daemon[4255]:last message repeated 4 times
Dec 19 16:47:20 ws-ljw console-kit-daemon[4255]: GLib-CRITICAL:
g_async_queue_push: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 16:53:00 ws-ljw console-kit-daemon[4255]: WARNING: Error waiting for
native console 25 activation: Bad file descr
iptor
...
Dec 19 17:13:09 ws-ljw console-kit-daemon[5408]: GLib-CRITICAL:
g_async_queue_push: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Dec 19 17:13:09 ws-ljw kernel: console-kit-dae[5408]: segfault at 0000000c eip
00cf7360 esp bf997d14 error 4

Additional info:
User authentication is done via LDAP over TLS and I get errors like
Dec 19 16:48:24 ws-ljw gdmgreeter[4577]: nss_ldap: failed to bind to LDAP server
ldaps://fs.icm.edu.pl/: Can't contact LDAP server
Dec 19 16:48:24 ws-ljw gdmgreeter[4577]: nss_ldap: failed to bind to LDAP server
ldaps://burza.icm.edu.pl/: Can't contact LDAP server
Dec 19 16:48:24 ws-ljw gdmgreeter[4577]: nss_ldap: could not search LDAP server
- Server is unavailable

even though I can get user information via `id' or ldapsearch without any problems.

If I start nscd, then it, too, starts complaining about not being able to bind
to LDAP server.

gdm-2.20.2-2.fc8
nscd-2.7-2
nss_ldap-257-4.fc8
Comment 1 Dominik 'Rathann' Mierzejewski 2007-12-19 11:27:21 EST
Created attachment 290039 [details]
console-kit-daemon crash trace
Comment 2 Dominik 'Rathann' Mierzejewski 2008-02-01 08:44:18 EST
Looks like one of the recent updates fixed that. I'll reopen if it happens again.

Note You need to log in before you can comment on or make changes to this bug.