Bug 426288 - There was an error communicating with RHN
There was an error communicating with RHN
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 14:58 EST by Clint Bowman
Modified: 2007-12-19 16:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 15:41:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clint Bowman 2007-12-19 14:58:17 EST
Description of problem:
Error Message:
    Your account does not have access to any channels matching (release='4',
arch='ia32e-redhat-linux')
If you have a registration number, please register with it first at
http://www.redhat.com/apps/activate/ and then try again.
Error Class Code: 19
Error Class Info: Architecture and OS version combination is not supported.


Version-Release number of selected component (if applicable):
2.6.18-8.1.10.el5 #1 SMP Thu Aug 30 20:43:28 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
Happens everytime since about Thanksgiving--wasn't there a yum update about then?

Steps to Reproduce:
1.yum update tzdata
2.or any other package!
3.
  
Actual results:


Expected results:
I suspect something in the yum config has been corrupted

Additional info:
Comment 1 James Antill 2007-12-19 15:41:08 EST
 You should phone up about account support, and/or check your account by
directly logging into rhn.redhat.com.

 There wasn't a yum update, although there was a yum-rhn-plugin update.
 But I'm very sure that it wouldn't have done something like this in the general
case (or I'd have seen many bug reports).
Comment 2 Clint Bowman 2007-12-19 16:01:45 EST
cat yum.repos.d/rhel-debuginfo.repo
name=Red Hat Enterprise Linux $releasever - $basearch - Debug
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/$basearch/Debuginfo/

but, as can be seen in the post above, $releasever seems to be '4' and $basearch
is 'ia32e-redhat-linux'

But that's not correct for this '5', 'x86_64' system.

Where are $releasever and $basearch defined for yum?

Note You need to log in before you can comment on or make changes to this bug.