Bug 426313 - Cannot connect to wireless network with public ssid, wep 128 bit pass phrase and dhcp
Cannot connect to wireless network with public ssid, wep 128 bit pass phrase ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 17:55 EST by Uwe Kubosch
Modified: 2008-02-02 14:51 EST (History)
4 users (show)

See Also:
Fixed In Version: Installed Packages NetworkManager.i386 1:0.7.0-0.8.svn3204.fc installed NetworkManager-glib.i386 1:0.7.0-0.8.svn3204.fc installed NetworkManager-gnome.i386 1:0.7.0-0.8.svn3204.fc install
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-02 13:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump of /var/log/messages (58.74 KB, text/plain)
2007-12-19 17:55 EST, Uwe Kubosch
no flags Details
dump of /var/log/dmesg (22.98 KB, text/plain)
2007-12-19 17:57 EST, Uwe Kubosch
no flags Details

  None (edit)
Description Uwe Kubosch 2007-12-19 17:55:09 EST
Description of problem:
Cannot connect to wireless access point using dhcp.  It looks like association
goes OK, both green lights on the NetworkManager applet light up, but dhcp does
not get an address.

Version-Release number of selected component (if applicable):
NetworkManager.i386                      1:0.7.0-0.6.6.svn3138. installed       
NetworkManager-glib.i386                 1:0.7.0-0.6.6.svn3138. installed       
NetworkManager-gnome.i386                1:0.7.0-0.6.6.svn3138. installed       
iwl3945-firmware.noarch                  2.14.1.5-2             installed       
kernel.i686                              2.6.23.8-63.fc8        installed       
kernel.i686                              2.6.23.9-85.fc8        installed       
dhcpv6-client.i386                       0.10-51.fc8            installed       
libdhcp.i386                             1.27-3.fc8             installed       
libdhcp4client.i386                      12:3.0.6-12.fc8        installed       
libdhcp6client.i386                      0.10-51.fc8            installed       


How reproducible:


Steps to Reproduce:
1. Boot
2. Select wireless network with public ssid and 128 bit wep pass-phrase
3. Network card seems to associate, both green lights on nm-applet light up
4. /var/log/messages lists that dhcp tries to get address, but fails

  
Actual results:
Connection fails

Expected results:
Successful connection

Additional info:
Tried with latest packages from updates, then latest packages from updates-testing.

Wired network with dhcp works.

This is an upgraded system originally installed with Fedora 7.

Wireless connection with same laptop, same access point, same wep key worked
under Fedora 7.
Comment 1 Uwe Kubosch 2007-12-19 17:55:09 EST
Created attachment 290075 [details]
Dump of /var/log/messages
Comment 2 Uwe Kubosch 2007-12-19 17:57:00 EST
Created attachment 290076 [details]
dump of /var/log/dmesg
Comment 3 Miroslav Pragl 2007-12-29 15:07:25 EST
same problem here. I try to create new wireless network (just becasue SSID is
hidden) and NetworkManager keeps asking for key and for ever. As soon as I
unhide SSID NetworkManager connects. FC8/i386,
NetworkManager-0.7.0-0.6.6.svn3109.fc8, iwl3945 WLAN adapter.

I found out (B.F.Magic!) that for example opening /closing system-config-network
SOMETIMES helps NM connect.

Tried on 2 different APs (WPA and WEP), same behavior.

Miroslav

Comment 4 Dan Williams 2007-12-31 10:58:32 EST
miroslav: there are known driver problems with iwl3945/iwl4965 and hidden SSID
networks.
Comment 5 Uwe Kubosch 2008-01-13 03:22:09 EST
Update:  I have tried connecting to other access points, but the result is the
same: network card associates fine, but dhcp gives no address.
Comment 6 Uwe Kubosch 2008-02-02 13:53:44 EST
It seems to work now.  I cannot say exactly which update fixed it.

Also, at least once I chose the wrong security mechanism.  NetworkManager promps
for WEP 128bit passphrase, even if the access point is configured for 128bit ASCII.
Comment 7 Uwe Kubosch 2008-02-02 13:55:07 EST
Here is my currently working setup:

Installed Packages
NetworkManager.i386                      1:0.7.0-0.8.svn3204.fc installed       
NetworkManager-glib.i386                 1:0.7.0-0.8.svn3204.fc installed       
NetworkManager-gnome.i386                1:0.7.0-0.8.svn3204.fc installed       
dhcpv6-client.i386                       1.0.4-1.fc9            installed       
iwl3945-firmware.noarch                  2.14.1.5-2             installed       
kernel.i686                              2.6.23.9-85.fc8        installed       
kernel.i686                              2.6.24-0.123.rc6.fc9   installed       
libdhcp.i386                             1.99.3-1.fc9           installed       
libdhcp4client.i386                      12:3.1.0-12.fc9        installed
Comment 8 Dan Williams 2008-02-02 14:51:58 EST
unfortunately there's no possibly way to figure out the WEP password/passphrase
-> key hashing option except to ask the user.  The AP doesn't advertise what it
uses, because everything really just uses binary keys underneath.  But to make
it easier for users to type things in, the manufacturers invented ASCII keys and
WEP passphrases, but didn't make it easy to distinguish between them for the
computer.

Note You need to log in before you can comment on or make changes to this bug.