Bug 426316 - Set-GID xterm unsets LD_LIBRARY_PATH
Set-GID xterm unsets LD_LIBRARY_PATH
Status: CLOSED DUPLICATE of bug 309691
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xterm (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 18:21 EST by Stephen Fralich
Modified: 2008-01-02 10:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 10:27:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Fralich 2007-12-19 18:21:22 EST
Description of problem:
Now that xterm is set-gid, it unsets LD_LIBRARY_PATH.  This is not desirable.

Version-Release number of selected component (if applicable): xterm-215-5.el5
Comment 1 Miroslav Lichvar 2008-01-02 10:27:58 EST
utempter needs to be fixed first so xterm doesn't need the setgid. (bug #315261).

*** This bug has been marked as a duplicate of 309691 ***

Note You need to log in before you can comment on or make changes to this bug.