Bug 426319 - after RHEL5 install on QS22, no console on SOL
after RHEL5 install on QS22, no console on SOL
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
other Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 19:36 EST by Scott Moser
Modified: 2007-12-19 20:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 20:49:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Moser 2007-12-19 19:36:58 EST
Description of problem:

I installed RHEL5u2 nightly build on a QS22 system (ibm-qs22-01 in
redhat westford lab).  The install was problem free, but on reboot, I
thought the sytem had hung.  This was because the system was configured
to boot with 'console=hvc0'.  The system was booting fine (and was
network-reachable afterwards).  I just couldn't see the console
messages.

How reproducible: 100%
Steps to Reproduce:
1. Install RHEL5u2 (likely RHEL5u1 GA works also) on QS22
2. Reboot
  
Actual results:
  No console messages on the SOL provided by the bladecenter.


Expected results:
  console messages should go to the SOL provided by the bladecenter.

Additional info:
  This problem is fixed simply by removing 'console=hvc0' from the
append line of yaboot.conf after successfully booting.
  I assumed that it was anaconda that decided to add these kernel
parameters (I could be wrong).

  I can provide access to the system for debugging if needed.
Comment 1 Scott Moser 2007-12-19 20:49:03 EST
Doh!
  I just realized that the kickstart file that I had used contained:

bootloader --location=partition --append="console=hvc0 rhgb quiet"

  This would quite obviously cause there to be 'console=hvc0' on the kernel
command line.  Sorry for this bad bug report.

  I wonder, if I do not specify any --append argument in a kickstart file, will
anaconda select the correct values ? (I just copied that line from somewhere).

Note You need to log in before you can comment on or make changes to this bug.