Bug 426338 - FutureFeature: lib directory names
FutureFeature: lib directory names
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 02:49 EST by The Source
Modified: 2013-01-09 20:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 08:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2007-12-20 02:49:45 EST
Description of problem:
In Fedora 8 x86-64 lib directories are /usr/lib and /usr/lib64. It might be more
convenient and provide more compatibility with libraries like alsa if directory
names are /usr/lib32 and /usr/lib (for 64 bit).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesse Keating 2007-12-20 08:35:27 EST
I don't see how this can possibly help.  It makes it so that you can't install
32bit packages on 64bit without rebuilding them to be "32 on 64" style.
Comment 2 The Source 2007-12-20 08:47:15 EST
I'm asking for this because many libs when I type 'make install' are installed
into /usr/lib without checking system architecture. They are compiled for 64 but
installed into 32bit lib directory and that is obviously wrong.
Comment 3 Jesse Keating 2007-12-20 09:05:11 EST
that's because you're likely doing it wrong.  But bugzilla isn't a support
channel.  I would recommend you take this issue up on one of the Fedora mailing
lists or forums, for information about how to properly compile software on 64bit
hosts.

Note You need to log in before you can comment on or make changes to this bug.