Bug 426348 - host, dig, and nslookup commands can't search relative-domainname
host, dig, and nslookup commands can't search relative-domainname
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Regression
: 426467 427181 427261 427822 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 05:57 EST by Kazutoshi Morioka
Modified: 2013-04-30 19:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: 9.5.0-22.b1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 20:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kazutoshi Morioka 2007-12-20 05:57:33 EST
Description of problem:
Commands from bind-utils package, host, dig, nslookup are broken.
When they append domain after relative-domainname, they lack a dot.
For example, assume your domain is "example.net",
and query "foobar.example.net" by invoking with argument "foobar",
these commands query "foobarexample.net" instead.

$ host -v foobar
Trying "foobarexample.net"       ### look this! ###
Trying "foobar"
Host foobar not found: 3(NXDOMAIN)
Received 98 bytes from 192.XXX.XXX.XXX#53 in 0 ms

Another problem; even with a trailing period, it's treated as a relative-domainname.

$ host foobar.
foobar.example.net has address 192.XXX.XXX.XXX

Other two commands, dig and nslookup shows same problem.

Version-Release number of selected component (if applicable):
bind-utils-9.5.0-20.b1.fc8

How reproducible:
Allways

Steps to Reproduce:
1.host RELATIVE-DOMAINNAME
  
Actual results:
$ host foobar
Host foobar not found: 3(NXDOMAIN)

Expected results:
$ host foobar.
foobar.example.net has address 192.XXX.XXX.XXX

Additional info:
I copied the host command from bind-utils-9.5.0-19.b1.fc8.i386.rpm,
and it works as expected with libs from bind-libs-9.5.0-20.b1.fc8.
Comment 1 Adam Tkac 2007-12-20 08:04:46 EST
Could you please test proposed update?
http://kojiweb.fedoraproject.org/koji/taskinfo?taskID=303059

Thanks, Adam
Comment 2 Kazutoshi Morioka 2007-12-20 09:52:21 EST
I downloaded bind-libs-9.5.0-20.1.b1.fc8.i386.rpm  and
bind-utils-9.5.0-20.1.b1.fc8.i386.rpm.
It works as expected.
Thanks.

I found that host from 9.5.0-20.1.b1.fc8 shows slightly different result than
one from 9.5.0-19.b1.fc8 for undefined top level domain.
But It seems that the old behavior looks strange, and the new one looks OK.

Old behavior (9.5.0-19.b1.fc8):
$ ./host.old notexsts.
./host.old: 'notexsts.' is not a legal name (unexpected end of input)

New behavior (9.5.0-20.1.b1.fc8):
$ host notexist.
Host notexist. not found: 3(NXDOMAIN)

And I apologizes that false bug report about dig command.
The dig command works as expected at any of 9.5.0-19.b1.fc8, 9.5.0-20.b1.fc8,
9.5.0-20.1.b1.fc8. 
That's my mistake.
Comment 3 Adam Tkac 2007-12-20 10:15:58 EST
Thanks for your testing. Update is already scheduled, will be avaliable soon
Comment 4 Adam Tkac 2007-12-21 05:46:33 EST
*** Bug 426467 has been marked as a duplicate of this bug. ***
Comment 5 Trevor Cordes 2007-12-24 09:31:47 EST
Me too!  Thanks for the quick solve.  I was banging my head against the wall for
10 mins before doing this bugzilla search.  Push the update soon, as this breaks
a lot of my scripts that rely on host.
Comment 6 Fedora Update System 2007-12-28 12:19:44 EST
bind-9.5.0-22.b1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'
Comment 7 Adam Tkac 2008-01-02 06:45:26 EST
*** Bug 427181 has been marked as a duplicate of this bug. ***
Comment 8 Adam Tkac 2008-01-02 12:15:44 EST
*** Bug 427261 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2008-01-06 20:13:01 EST
bind-9.5.0-22.b1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Petr Šplíchal 2008-01-08 06:17:41 EST
*** Bug 427822 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.