Bug 426358 - BCM5706 does not work with 1.6.8 driver
BCM5706 does not work with 1.6.8 driver
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Andy Gospodarek
Martin Jenner
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 09:19 EST by Marcus Alves Grando
Modified: 2014-06-29 18:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 13:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg bnx2 1.6.8 (21.85 KB, text/plain)
2007-12-21 07:37 EST, Marcus Alves Grando
no flags Details

  None (edit)
Description Marcus Alves Grando 2007-12-20 09:19:17 EST
Well, i'm trying to boot one HP DL385G2 (6 broadcom BCM5706 with bnx2 1.6.8
driver), but all nics does not work.

With bnx2 1.5.11 works fine all nics.

I see in dmesg that memory address are different between drivers... see below.

I already test in 1.6.8 driver pci=bfsort and nobfsort but does not work too.

--dmesg 1.5.11 driver--
divert: not allocating divert_blk for non-ethernet device lo
Broadcom NetXtreme II Gigabit Ethernet Driver bnx2 v1.5.11-rh (June 4, 2007)
divert: allocating divert_blk for eth0
eth0: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f4000000, IRQ 209, node addr 0019bbcde27c
divert: allocating divert_blk for eth1
eth1: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f6000000, IRQ 193, node addr 0019bbcde27e
divert: allocating divert_blk for eth2
eth2: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f0000000, IRQ 185, node addr 0019bbcdd4fc
divert: allocating divert_blk for eth3
eth3: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f2000000, IRQ 209, node addr 0019bbcdd4fe
divert: allocating divert_blk for eth4
eth4: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem fc000000, IRQ 217, node addr 001635820a2e
divert: allocating divert_blk for eth5
eth5: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem fa000000, IRQ 225, node addr 001635820a30
bnx2: eth0 NIC Link is Up, 1000 Mbps full duplex
bnx2: eth1 NIC Link is Up, 1000 Mbps full duplex
--
--dmesg 1.6.8--
divert: not allocating divert_blk for non-ethernet device lo
Broadcom NetXtreme II Gigabit Ethernet Driver bnx2 v1.6.8 (October 17, 2007)
divert: allocating divert_blk for eth0
eth0: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f0000000, IRQ 185, node addr 0019bbcdd4fc
divert: allocating divert_blk for eth1
eth1: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f2000000, IRQ 209, node addr 0019bbcdd4fe
divert: allocating divert_blk for eth2
eth2: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f4000000, IRQ 209, node addr 0019bbcde27c
divert: allocating divert_blk for eth3
eth3: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem f6000000, IRQ 193, node addr 0019bbcde27e
divert: allocating divert_blk for eth4
eth4: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem fc000000, IRQ 217, node addr 001635820a2e
divert: allocating divert_blk for eth5
eth5: Broadcom NetXtreme II BCM5706 1000Base-T (A2) PCI-X 64-bit 100MHz found at
mem fa000000, IRQ 225, node addr 001635820a30
--
--/proc/interrupts 1.6.8--
           CPU0       CPU1	 CPU2       CPU3       CPU4	  CPU5       CPU6	CPU7
  0:	  30643      40033	40016	   40030      40012	 38133      30014      55711 
  IO-APIC-edge  timer
  1:          0          0          0          0          0          0         
0          9    IO-APIC-edge  i8042
  8:          0          0          1          0          0          0         
0          3    IO-APIC-edge  rtc
  9:          0          0          0          0          0          0         
0          0   IO-APIC-level  acpi
 14:          0          0          0          0          0          0         
0         23    IO-APIC-edge  ide0
 66:	  13695          0	 1110          0          0          0          0    
     0	   PCI-MSI-X  cciss0
169:          0          0          0          0          0          0         
1         38   IO-APIC-level  ohci_hcd
177:          0          0          0          0          0          0         
0         18   IO-APIC-level  ehci_hcd
201:         48         72        126          0        704          0       
328         79   IO-APIC-level  uhci_hcd
NMI:          0          0          0          0          0          0         
0          0
LOC:     313879     313987     313986     313985     313984     313983    
313982     313981
ERR:          1
MIS:          0
--
--/proc/interrupts 1.5.11--
           CPU0       CPU1	 CPU2       CPU3       CPU4	  CPU5       CPU6	CPU7
  0:        588      10031	10003	   10036      10003	 10031      10018     
64343    IO-APIC-edge  timer
  1:          0          0          0          0          0          0         
0          9    IO-APIC-edge  i8042
  8:          0          0          0          0          0          0         
0          3    IO-APIC-edge  rtc
  9:          0          0          0          0          0          0         
0          0   IO-APIC-level  acpi
 14:          0          0          0          0          0          0         
6         17    IO-APIC-edge  ide0
 66:	   5396          0          0          0       9571          0        248 
        0	   PCI-MSI-X  cciss0
169:          0          0          0          0          0          0         
1         38   IO-APIC-level  ohci_hcd
177:          0          0          0          0          0          0         
0         18   IO-APIC-level  ehci_hcd
193:          0          0       9694          0          0          0         
0         26   IO-APIC-level  eth1
201:          0          4          0          0          0          0         
0        115   IO-APIC-level  uhci_hcd
209:       3497          0          0          0          0          0         
0        182   IO-APIC-level  eth0
NMI:          0          0          0          0          0          0         
0          0
LOC:     124375     124480     124479     124478     124477     124476    
124475     124474
ERR:          1
MIS:          0
--
--lspci -n 1.6.8 and 1.5.11 are same--
03:04.0 Class 0200: 14e4:164a (rev 02)
04:05.0 Class 0200: 14e4:164a (rev 02)
06:04.0 Class 0200: 14e4:164a (rev 02)
07:05.0 Class 0200: 14e4:164a (rev 02)
41:01.0 Class 0200: 14e4:164a (rev 02)
41:02.0 Class 0200: 14e4:164a (rev 02)
--

Any idea?

Regards
Comment 1 Marcus Alves Grando 2007-12-20 09:25:15 EST
I forget to say, kernel is 2.6.9-67.0.1 and 1.6.8 driver i take from agospoda page.

http://people.redhat.com/agospoda/rhel4/bnx2-update-1_6_8.patch

Regards
Comment 2 Andy Gospodarek 2007-12-20 09:39:22 EST
Thanks for the feedback on my test kernels!  Sorry it did not work on your
system.  I will take a look at this problem and re-work the patch.

I'm not sure bugzilla is the place to tracking those changes, so I will close
this.  Feel free to email me directly (gospo@redhat.com) any time you have a
problem (or success) with my test kernels.
Comment 3 Andy Gospodarek 2007-12-20 11:13:25 EST
I'll reopen this, since it seems like a good way to track the issue.  

This is most-likely related to some of the MSI/INTX issues that were addressed
upstream and the 'fixes' there break the driver in RHEL.
Comment 4 Andy Gospodarek 2007-12-20 14:42:03 EST
Actually now that I think about this, it maybe related to firmware-load changes
upstream and my incorrect backport of those changes for rhel.  When running
1.6.8 did you see any errors like this in the logs:

bnx2: eth0: Firmware decompression error

or something similar?
Comment 5 Marcus Alves Grando 2007-12-21 07:36:51 EST
(In reply to comment #4)
> Actually now that I think about this, it maybe related to firmware-load changes
> upstream and my incorrect backport of those changes for rhel.  When running
> 1.6.8 did you see any errors like this in the logs:
> 
> bnx2: eth0: Firmware decompression error
> 
> or something similar?

No, there's no message like that.

I'll attach dmesg for you.

Thanks
Comment 6 Marcus Alves Grando 2007-12-21 07:37:30 EST
Created attachment 290233 [details]
dmesg bnx2 1.6.8
Comment 7 Marcus Alves Grando 2008-03-24 20:54:21 EDT
Andy,

I'll test tomorrow 1.6.9 driver from your page. After that I post results.

Regards
Comment 8 Marcus Alves Grando 2008-03-25 09:48:40 EDT
Ok. 1.6.9 doesn't work either.

I think that's a problem on firmware. See below.

bnx2-1.6.9# ethtool -i eth0
driver: bnx2
version: 1.6.9
firmware-version: 1.9.6
bus-info: 0000:06:04.0

bnx2-1.6.9# ethtool -i eth1
driver: bnx2
version: 1.6.9
firmware-version: 1.9.6
bus-info: 0000:07:05.0

# ethtool -i eth0 
driver: bnx2
version: 1.5.11-rh
firmware-version: 1.9.6
bus-info: 0000:06:04.0

# ethtool -i eth1 
driver: bnx2
version: 1.5.11-rh
firmware-version: 1.9.6
bus-info: 0000:07:05.0

bnx2-1.6.9# ethtool -d eth0 | grep -v 0x00
Offset	Value
--------	-----

bnx2-1.6.9# ethtool -d eth1 | grep -v 0x00
Offset	Value
--------	-----

bnx2-1.5.11-rh# ethtool -d eth0 | grep -v 0x00
Offset	Value
--------	-----
00	0xe4
01	0x14
02	0x4a
03	0x16
04	0x56
05	0x01
[...]
26716	0x4e
26717	0x4f
26718	0x50
26719	0x51
26889	0x80
26895	0x08

# ethtool -d eth1 | grep -v 0x00
Offset	Value
--------	-----
00	0xe4
01	0x14
02	0x4a
03	0x16
04	0x56
05	0x01
06	0xb0
07	0x02
08	0x02
[...]
26713	0x4b
26714	0x4c
26715	0x4d
26716	0x4e
26717	0x4f
26718	0x50
26719	0x51
26889	0x80
26895	0x0a

If you need more info, please contact me.

Thanks
Comment 9 Andy Gospodarek 2008-03-25 10:15:52 EDT
I just tested an updated patch on one of my systems and it looks good.  This
patch will be included in my gtest.40 kernels -- I will probably build those
later today or tomorrow.
Comment 10 Marcus Alves Grando 2008-04-04 17:35:05 EDT
Andy,

I've tested 2.6.9-68.28 on my servers and works fine now, include Blades.

You can close this now.

Thanks
Comment 11 Andy Gospodarek 2008-04-15 13:54:30 EDT
I have meant to close this out out since it was found and resolved with my test
kernels.

Note You need to log in before you can comment on or make changes to this bug.