Bug 426366 - perftest stops after random interval when sending large messages
perftest stops after random interval when sending large messages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gordon Sim
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-20 10:05 EST by Kim van der Riet
Modified: 2011-08-12 12:23 EDT (History)
0 users

See Also:
Fixed In Version: qpidd-0.2-24.el5 and qpidc-0.2-24.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 11:46:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pstack for perftest and broker taken while condition existed. (9.39 KB, text/plain)
2007-12-20 10:05 EST, Kim van der Riet
no flags Details

  None (edit)
Description Kim van der Riet 2007-12-20 10:05:10 EST
Perftest can stop after a random interval (usually between 10 and 200
iterations) when sending large transinent messages on et_virt07. I managed to
see this three times consecutively (each time after stopping and restarting the
broker), but have not been able to reproduce it since then. As tasksets are used
in this configuration, to reproduce exactly a box with 8 cores will be required,
although it is not clear that this has bearing on the issue.

Broker configurataion:
taskset -c 0,1,2,3 ../qpidd -s ~/jrnltest/store/lib/.libs/libbdbstore.so
--store-dir tmp

Client configuration:
while taskset -c 6,7 ./perftest --nsubs 1 --npubs 1 --count=10 --qt 4 --size
100000  --durable no -s ; do true ; done

Result:
After between 10 and 200 iteration, the client simply stopped. I attach a pstack
of both the broker and client, which was identical in each case which I
observed. In short, all broker threads were idle, while the clinet had one
thread waiting for a notification.
Comment 1 Kim van der Riet 2007-12-20 10:05:10 EST
Created attachment 290157 [details]
pstack for perftest and broker taken while condition existed.
Comment 2 Kim van der Riet 2007-12-20 10:48:45 EST
I managed to reprocuc the problem without the taskset part of the commands for
both the broker and perftest, this time with 4 publishers and consumers. It can
take a few iterations, though, in this case, 822.

../qpidd -s ~/jrnltest/store/lib/.libs/libbdbstore.so --store-dir tmp

while ./perftest --nsubs 4 --npubs 4 --count=12 --qt 4 --size 100000  --durable
no -s ; do true ; done
Comment 3 Gordon Sim 2007-12-21 10:16:50 EST
Fixed in qpid rev 606176. This was due to a bug in the completion tracking logic.
Comment 4 Mike Bonnet 2008-02-29 11:46:52 EST
Fixed in qpidd-0.2-24.el5 and qpidc-0.2-24.el5

Note You need to log in before you can comment on or make changes to this bug.