Bug 426398 - OpenAL stopped working
OpenAL stopped working
Product: Fedora
Classification: Fedora
Component: openal (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-20 14:39 EST by The Source
Modified: 2007-12-21 03:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-21 03:08:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description The Source 2007-12-20 14:39:10 EST
Description of problem:
I updated openal packages today and sound disappeared in Unreal Tournament
2003/2004. Also their processes do not exit completely. They remain in system
doing nothing.

Version-Release number of selected component (if applicable):
0.0.9-0.13.20060204cvs.fc8 (both i686 and x86_64)

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 The Source 2007-12-20 14:48:07 EST
Tested more games (glest, solarwolf). Looks like everything that uses openal
lost sound.
Comment 2 Andreas Bierfert 2007-12-20 18:20:00 EST
Please take a look at /etc/openalrc. If everything worked before please
uncomment the line '(define devices '(sdl))' and everything should work like
before. Please let me know if that helps.
Comment 3 The Source 2007-12-21 00:55:47 EST
1. sdl device was not commented. But alsa-native was. Uncommenting it solved the
2. Strangely I have found two openalrc files in /etc: openalrc and
openalrc.rpmnew. Their contents were identical.
Comment 4 Andreas Bierfert 2007-12-21 03:08:08 EST
Hm that is strange. openalrc should have had (define devices '(sdl)) in it and
not alsa... except on F-7. But if it works now thats ok.
Comment 5 The Source 2007-12-21 03:21:24 EST
Yes, I figured out that this is some kind of SDL problem (perhaps connected to
pulse audio), not OpenAL.

Note You need to log in before you can comment on or make changes to this bug.