Bug 426474 - new sequence for partitioning and formatting filesystems leaves systems unuseable in the face of subsequent errors
new sequence for partitioning and formatting filesystems leaves systems unuse...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 06:17 EST by G.Wolfe Woodbury
Modified: 2007-12-21 09:09 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 09:09:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2007-12-21 06:17:04 EST
Description of problem:
  the installer now seems to commit and format filesystems immediately rather
than waiting until ready to begin the installing.  This leaves the system in an
unusable state when a subsequent error [e.g. BZ 426444] causes the install to fail.

Version-Release number of selected component (if applicable):
  anaconda 11.4.0.11

How reproducible:
 always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
  I much prefer the older behaviour of waiting until much later in the install
process before committing partitioning and formatting filesystems.

Additional info:
Comment 1 Jeremy Katz 2007-12-21 09:09:15 EST
The problem is that resizing is, fundamentally, an operation which has a chance
of not being able to do exactly what was estimated, etc.  So we can't just
assume like we always have in the past that our partitioning will definitely be
able to match up.  Also, we're going to take advantage of the "immediate" commit
so that if your partitioning does fail for some reason, then we can give you a
better chance to fix it up.

Also, we're going to be moving some other things around so the sequence will end
up being smaller config bits, partitioning, package selection, install.  And
we'll need to have partitioning committed for package selection so that you can
actually add repositories from CDs other than the one that you're running the
installer from.


Note You need to log in before you can comment on or make changes to this bug.