Bug 426475 - SDL headers contain c++ style comments causing problems compiling with -ansi
Summary: SDL headers contain c++ style comments causing problems compiling with -ansi
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-21 11:56 UTC by Hans de Goede
Modified: 2008-01-22 15:47 UTC (History)
1 user (show)

Fixed In Version: 1.2.13-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 15:47:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2007-12-21 11:56:49 UTC
While reviewing a package today I got lots and lots of these warnings during the
build:
/usr/include/SDL/begin_code.h:94:8: warning: extra tokens at end of #endif directive

This is caused by this line:
#endif //__SYMBIAN32__

Notice the c++ style comment, please change this (and the one the line above) to
normal C comments.

Comment 1 Fedora Update System 2008-01-11 22:11:12 UTC
SDL-1.2.13-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update SDL'

Comment 2 Fedora Update System 2008-01-22 15:47:08 UTC
SDL-1.2.13-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.