This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 426513 - Hangs getting passwords
Hangs getting passwords
Status: CLOSED DUPLICATE of bug 416991
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 11:49 EST by Bastien Nocera
Modified: 2007-12-21 12:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 12:19:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-12-21 11:49:43 EST
evolution-2.21.4-1.fc9
evolution-data-server-2.21.4-1.fc9
gnome-keyring-2.21.4-1.fc9

Evolution hangs either on startup, or after clicking "Send & Receive".

Thread 3 (Thread 0xb51aab90 (LWP 29355)):
#0  0x00110402 in __kernel_vsyscall ()
#1  0x00cc7353 in __poll (fds=<value optimized out>, nfds=<value optimized out>,
timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x055f6583 in g_main_context_iterate (context=<value optimized out>,
block=<value optimized out>, dispatch=<value optimized out>, self=Could not find
the frame base for "g_main_context_iterate".
) at gmain.c:2996
#3  0x055f68f9 in IA__g_main_loop_run (loop=<value optimized out>) at gmain.c:2898
#4  0x0078f234 in ?? () from /usr/lib/libnm_glib.so.0
#5  0x0561672f in g_thread_create_proxy (data=<value optimized out>) at
gthread.c:635
#6  0x00d914fb in start_thread (arg=<value optimized out>) at pthread_create.c:297
#7  0x00cd142e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb3176b90 (LWP 29358)):
#0  0x00110402 in __kernel_vsyscall ()
#1  0x00d95605 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x055d5d82 in g_async_queue_pop_intern_unlocked (queue=<value optimized
out>, try=<value optimized out>, end_time=<value optimized out>) at
gasyncqueue.c:334
#3  0x00445fe5 in e_msgport_wait (msgport=0x9060748) at e-msgport.c:684
#4  0x003390de in ep_msg_send (msg=0xb08ad2a8) at e-passwords.c:298
#5  0x0033ac45 in e_passwords_get_password (component_name=0x12f9462 "Mail",
key=0xb08ad320 "imap://bnocera@pobox.surrey.redhat.com/") at e-passwords.c:1121
#6  0x012c9fab in get_password (session=0x8e96ce0, service=0x904f090,
domain=0x12f9462 "Mail", 
    prompt=0xb08aeb68 "Please enter the IMAP password for
bnocera@pobox.surrey.redhat.com", item=0x307e77b "password", flags=4,
ex=0x905a550) at mail-session.c:184
#7  0x002fa645 in camel_session_get_password (session=0x8e96ce0,
service=0x904f090, domain=0x0, 
    prompt=0xb08aeb68 "Please enter the IMAP password for
bnocera@pobox.surrey.redhat.com", item=0x307e77b "password", flags=4,
ex=0x905a550) at camel-session.c:376
#8  0x0307842e in imap_connect_online (service=0x904f090, ex=0x905a550) at
camel-imap-store.c:1379
#9  0x002d92d6 in disco_connect (service=0x904f090, ex=0x905a550) at
camel-disco-store.c:162
#10 0x002f943f in camel_service_connect (service=0x904f090, ex=0x905a550) at
camel-service.c:371
#11 0x03072a5c in camel_imap_store_connected (store=0x904f090, ex=0x905a550) at
camel-imap-store.c:2997
#12 0x030741a3 in refresh_refresh (session=0x8e96ce0, msg=0x905a520) at
camel-imap-store.c:2647
#13 0x002faba2 in session_thread_proxy (msg=0x905a520, session=0x8e96ce0) at
camel-session.c:532
#14 0x056182b8 in g_thread_pool_thread_proxy (data=<value optimized out>) at
gthreadpool.c:265
#15 0x0561672f in g_thread_create_proxy (data=<value optimized out>) at
gthread.c:635
#16 0x00d914fb in start_thread (arg=<value optimized out>) at pthread_create.c:297
#17 0x00cd142e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7edf710 (LWP 29319)):
#0  0x00110402 in __kernel_vsyscall ()
#1  0x00d9854b in read () from /lib/libpthread.so.0
#2  0x005b2fd0 in ?? () from /usr/lib/libgnome-keyring.so.0
#3  0x005b4398 in ?? () from /usr/lib/libgnome-keyring.so.0
#4  0x005b480e in gnome_keyring_find_items_sync () from
/usr/lib/libgnome-keyring.so.0
#5  0x00339476 in ep_get_password (msg=0xb08ad2a8) at e-passwords.c:702
#6  0x00338fd5 in ep_idle_dispatch (data=0x0) at e-passwords.c:237
#7  0x055f1541 in g_idle_dispatch (source=Could not find the frame base for
"g_idle_dispatch".
) at gmain.c:4132
#8  0x055f310c in IA__g_main_context_dispatch (context=<value optimized out>) at
gmain.c:2061
#9  0x055f654f in g_main_context_iterate (context=<value optimized out>,
block=<value optimized out>, dispatch=<value optimized out>, self=Could not find
the frame base for "g_main_context_iterate".
) at gmain.c:2694
#10 0x055f68f9 in IA__g_main_loop_run (loop=<value optimized out>) at gmain.c:2898
#11 0x0089c813 in bonobo_main () at bonobo-main.c:311
#12 0x0805ed51 in main (argc=2, argv=0xbfe0da94) at main.c:700
#13 0x00c114a0 in __libc_start_main (main=Could not find the frame base for
"__libc_start_main".
) at libc-start.c:220
#14 0x0804f781 in _start ()
#0  0x00110402 in __kernel_vsyscall ()
Comment 1 Bastien Nocera 2007-12-21 11:58:13 EST
Upgrading gnome-keyring *and* restarting the session with a new
gnome-keyring-daemon fixed the problem.

It seems that gnome-keyring has no facilities for erroring when the libraries
can't talk to an older daemon.
Comment 2 Matthew Barnes 2007-12-21 12:19:03 EST

*** This bug has been marked as a duplicate of 416991 ***

Note You need to log in before you can comment on or make changes to this bug.