Bug 426521 - Latest metacity is unacceptably slow.
Latest metacity is unacceptably slow.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 14:13 EST by Ralph Loader
Modified: 2014-06-18 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 21:57:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Loader 2007-12-21 14:13:47 EST
Dragging a window around the screen with the latest metacity is unacceptably
slow; it moves the window in jerks about once per second.

Old versions of metacity moved the window smoothly, I guess about 20 times per
second.

CPU usage goes to 100% while this is happening.

I'm guessing that this is due to the alpha-blended composite-manager eye-candy?
 I suspect that that needs to be turned off on machines where it is not hardware
accelerated by the graphics card.

Similarly, doing a hide-all-windows on desktop followed by a show-all-windows is
extremely slow, about 1 second per window.

This is with metacity-2.21.5-2.fc9.
Comment 1 Søren Sandmann Pedersen 2007-12-21 21:27:56 EST
You can turn off the compositor with gconf-editor by going to
apps/metacity/general/compositing_manager and unsetting the checkbox.

I don't believe this is turned on by default, so it may have picked up an old
setting on your system.
Comment 2 Ralph Loader 2007-12-21 21:57:41 EST
Thanks, that works.

I'll resolve this as Not-a-bug.

But I don't remember turning this on via gconf-editor (it's not like I normally
ever run gconf-editor), so I'm not quite sure how it got turned on.

Note You need to log in before you can comment on or make changes to this bug.