Bug 426524 - SEGV crash installing kernel-2.6.24-0.118.rc5.git6.fc9
Summary: SEGV crash installing kernel-2.6.24-0.118.rc5.git6.fc9
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-21 19:56 UTC by Tom London
Modified: 2008-03-02 17:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 17:33:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2007-12-21 19:56:53 UTC
Description of problem:
I get this trying to install kernel-2.6.24-0.118.rc5.git6.fc9 (i686):

Running Transaction
  Installing: kernel                       ######################### [1/2] 
nash received SIGSEGV!  Backtrace (11):
/sbin/nash[0x805315a]
[0x110440]
/lib/libglib-2.0.so.0[0x2701a3]
/usr/lib/libbdevid.so.6.0.24(bdevid_module_unload_all+0x31)[0x8cfe37]
/usr/lib/libbdevid.so.6.0.24(bdevid_destroy+0x2d)[0x8cf57c]
/usr/lib/libnash.so.6.0.24[0x8c5198]
/usr/lib/libnash.so.6.0.24(nash_vitals_destroy_probes+0x3f)[0x8c5810]
/usr/lib/libnash.so.6.0.24(_nashFreeContext+0x1c)[0x8b5fd6]
/sbin/nash[0x80536f4]
/lib/libc.so.6(__libc_start_main+0xe0)[0x72a4a0]
/sbin/nash[0x804ae71]
error: %post(kernel-2.6.24-0.118.rc5.git6.fc9.i686) scriptlet failed, signal 2
[root@localhost ~]# 

Version-Release number of selected component (if applicable):
mkinitrd-6.0.24-1.fc9

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Michal Jaegermann 2007-12-21 20:29:54 UTC
The same on x86_64 with mkinitrd-6.0.24-1.fc9.

  Installing: kernel                       ####################### [28/76]
nash received SIGSEGV!  Backtrace (12):
/sbin/nash[0x40c7c9]
/lib64/libc.so.6[0x33e2631210]
/lib64/libglib-2.0.so.0[0x2aaaab394a89]
/lib64/libglib-2.0.so.0[0x2aaaab394e21]
/usr/lib64/libbdevid.so.6.0.24(bdevid_module_unload_all+0x24)[0x33e4202411]
/usr/lib64/libbdevid.so.6.0.24(bdevid_destroy+0x29)[0x33e4201bef]
/usr/lib64/libnash.so.6.0.24[0x33e4615ffa]
/usr/lib64/libnash.so.6.0.24(nash_vitals_destroy_probes+0x3a)[0x33e4616679]
/usr/lib64/libnash.so.6.0.24(_nashFreeContext+0x16)[0x33e4606f04]
/sbin/nash[0x40ccd0]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x33e261e1c4]
/sbin/nash[0x404179]

A look at processes shows:
root      9088  0.0  0.2  84992  1296 pts/0    S+   13:04   0:00  |       \_
/bin/bash /sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install
2.6.24-0.118.rc5.git6.fc9
root      9097  0.0  0.3  85520  1928 pts/0    S+   13:04   0:00  |           \_
/bin/bash --norc /sbin/mkinitrd --allow-missing -f
/boot/initrd-2.6.24-0.118.rc5.git6.fc9.img 2.6.24-0.118.rc5.git6.fc9
root      9172  0.0  0.2  85520  1140 pts/0    S+   13:04   0:00  |            
  \_ /bin/bash --norc /sbin/mkinitrd --allow-missing -f
/boot/initrd-2.6.24-0.118.rc5.git6.fc9.img 2.6.24-0.118.rc5.git6.fc9
root      9173  0.0  0.2  85520  1116 pts/0    S+   13:04   0:00  |            
      \_ /bin/bash --norc /sbin/mkinitrd --allow-missing -f
/boot/initrd-2.6.24-0.118.rc5.git6.fc9.img 2.6.24-0.118.rc5.git6.fc9
root      9175  2.8  0.4  48660  2164 pts/0    S+   13:04   0:04  |            
          \_ /sbin/nash --forcequiet

and everything just sits there and waits.

Only after 'kill 9088' I see:

/var/tmp/rpm-tmp.62713: line 6:  9088 Terminated             
/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install
2.6.24-0.118.rc5.git6.fc9
error: %post(kernel-2.6.24-0.118.rc5.git6.fc9.x86_64) scriptlet failed, exit
status 143

and yum continues with the remainder of that transaction.

An attempt to rerun mkinitrd with -v flag shows:

Creating initramfs
Looking for deps of module ehci-hcd
Looking for deps of module ohci-hcd
Looking for deps of module uhci-hcd
Looking for deps of module ext3: mbcache jbd
Looking for deps of module mbcache
Looking for deps of module jbd
nash received SIGSEGV!  Backtrace (12):
.....

and that is it.

After installing
libbdevid-python-6.0.25-2.fc9.x86_64.rpm
mkinitrd-6.0.25-2.fc9.x86_64.rpm
mkinitrd-devel-6.0.25-2.fc9.x86_64.rpm
nash-6.0.25-2.fc9.x86_64.rpm
from http://koji.fedoraproject.org/koji/packageinfo?packageID=219
I can build initrd again.


Comment 2 Tom London 2007-12-21 20:49:33 UTC
I can confirm: on i686 updating to 6.0.25-2.fc9 makes this work.

Comment 3 James Morris 2007-12-22 01:38:02 UTC
6.0.25-2 works for me on x86_64, too.


Comment 4 Håvard Wigtil 2008-01-13 11:23:38 UTC
I have the same or a similar problem (different backtrace). 
With mkinitrd-6.0.28-1.fc9 and trying to install
kernel-2.6.24-0.147.rc7.git2.fc9 i get this backtrace in the terminal window: 

  Installing: kernel                       ######################### [1/1] 
nash received SIGSEGV!  Backtrace (20):
/sbin/nash[0x805385d]
[0x130440]
/usr/lib/libnash.so.6.0.28(nashDmDevGetType+0xc2)[0x13f816]
/usr/lib/libnash.so.6.0.28[0x1419c3]
/usr/lib/libnash.so.6.0.28[0x141a9d]
/usr/lib/libnash.so.6.0.28[0x141c69]
/usr/lib/libnash.so.6.0.28(nash_dev_tree_process_bdev+0xd4)[0x1407c3]
/usr/lib/libnash.so.6.0.28[0x140af2]
/usr/lib/libnash.so.6.0.28[0x140c66]
/usr/lib/libnash.so.6.0.28(nash_dev_tree_add_sysfs_dir+0x48)[0x140a28]
/usr/lib/libnash.so.6.0.28(nash_dev_tree_populate_from_sysfs+0x27)[0x140d0d]
/usr/lib/libnash.so.6.0.28(nashBdevIterNewPoll+0x74)[0x13be03]
/usr/lib/libnash.so.6.0.28[0x13c17a]
/usr/lib/libnash.so.6.0.28(nashFindFsByLabel+0x2e)[0x13c33c]
/usr/lib/libnash.so.6.0.28(nashAGetPathBySpec+0x69)[0x13c4c2]
/sbin/nash[0x804f2a5]
/sbin/nash[0x80536c5]
/sbin/nash[0x8053dd6]
/lib/libc.so.6(__libc_start_main+0xe0)[0x48b4a0]
/sbin/nash[0x804aeb1]


Comment 5 Tom London 2008-03-02 17:33:24 UTC
Been fixed for a while.

Closing.


Note You need to log in before you can comment on or make changes to this bug.