This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 426534 - TB29ec97ad ini.py:563:readfp:UnboundLocalError: local variable 'line' referenced before assignment
TB29ec97ad ini.py:563:readfp:UnboundLocalError: local variable 'line' referen...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-iniparse (Show other bugs)
8
athlon Linux
low Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 16:18 EST by Black Knight
Modified: 2008-02-21 07:32 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 07:32:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Black Knight 2007-12-21 16:18:20 EST
+++ This bug was initially created as a clone of Bug #426326 +++

When I try to update, or add remove software I recieve this message:

exception occurred 

An unhandled exception has occurred.  This is most likely a bug.  Please save
the crash dump and file a detailed bug report against pirut at
https://bugzilla.redhat.com/bugzilla

Component: pirut
Summary: TB29ec97ad ini.py:563:readfp:UnboundLocalError: local variable 'line'
referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 614, in <module>
    main()
  File "/usr/sbin/pup", line 606, in main
    pup = PackageUpdater(not options.autoapply, options.config)
  File "/usr/sbin/pup", line 85, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 129, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 113, in
doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 164, in _getConfig
    self.getReposFromConfig()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 229, in
getReposFromConfig
    parser.readfp(confpp_obj)
  File "/usr/lib/python2.5/site-packages/iniparse/compat.py", line 106, in readfp
    self.data.readfp(fp)
  File "/usr/lib/python2.5/site-packages/iniparse/ini.py", line 563, in readfp
    if line and line[-1]=='\n':
UnboundLocalError: local variable 'line' referenced before assignment

-- Additional comment from blackknight2500@yahoo.com on 2007-12-19 21:22 EST --
Created an attachment (id=290100)
 TB29ec97ad ini.py:563:readfp:UnboundLocalError: local variable 'line'
referenced before assignment


-- Additional comment from tim.lauridsen@googlemail.com on 2007-12-20 03:25 EST --
Fixed in the latest version of python-iniparse please update.

-- Additional comment from blackknight2500@yahoo.com on 2007-12-20 18:34 EST --
The problem is I get this error message when I update.

-- Additional comment from blackknight2500@yahoo.com on 2007-12-20 18:55 EST --
This is an exception that occurred when I update:

An unhandled exception has occurred.  This is most likely a bug.  Please save
the crash dump and file a detailed bug report against pirut at
https://bugzilla.redhat.com/bugzilla

Thank you.
Comment 1 Tim Lauridsen 2008-02-21 07:32:49 EST
this issue is fixed in the latest verisons of python-iniparse.

File "/usr/lib/python2.5/site-packages/iniparse/ini.py", line 563, in readfp
    if line and line[-1]=='\n':

(this is line 564, in the latest releases)

Note You need to log in before you can comment on or make changes to this bug.