Bug 426560 - yum resolvedep <filename> is non-functional
yum resolvedep <filename> is non-functional
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 388761
  Show dependency treegraph
 
Reported: 2007-12-22 01:21 EST by Ralf Corsepius
Modified: 2014-01-21 18:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-22 08:27:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2007-12-22 01:21:01 EST
Description of problem:

yum resolvedep can't resolve filedeps.

# yum resolvedep /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
Importing additional filelist information
No Package Found for /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
Version-Release number of selected component (if applicable):


How reproducible:
deterministic.

Steps to Reproduce:

# yum resolvedep /usr/share/fonts/liberation/LiberationSerif-Italic.ttf
Importing additional filelist information
No Package Found for /usr/share/fonts/liberation/LiberationSerif-Italic.ttf

Version-Release number of selected component (if applicable):
yum-3.2.8-2.fc8

Actual results:
see above.

Expected results:
Correct package name.

similar to
# repoquery --whatprovides \
/usr/share/fonts/liberation/LiberationSerif-Italic.ttf
liberation-fonts-0:0.2-3.fc8.noarch

Additional info:

This bug breaks building packages in mock.
cf. https://bugzilla.redhat.com/show_bug.cgi?id=388761

Excerpt from a mock run's root.log:
...
DEBUG backend.py:473:  /usr/bin/yum --installroot
/var/lib/mock/fedora-8-x86_64/root  resolvedep  ccache  'bison'
'/usr/share/fonts/liberation/LiberationSerif-Italic.ttf'
....
DEBUG util.py:239:  run cmd timeout(0): /usr/bin/yum --installroot
/var/lib/mock/fedora-8-x86_64/root  resolvedep  ccache  'bison'
'/usr/share/fonts/liberation/LiberationSerif-Italic.ttf'
DEBUG util.py:212:  Ran setarch 'x86_64'
DEBUG util.py:260:  0:ccache-2.4-11.fc8.x86_64
DEBUG util.py:260:  0:bison-2.3-4.fc8.x86_64
DEBUG util.py:260:  No Package Found for
/usr/share/fonts/liberation/LiberationSerif-Italic.ttf
...
Comment 1 Jesse Keating 2007-12-22 08:27:32 EST
This is because you're running yum as non-root and it doesn't have privileges to
download the filelists repodata to find that file.  If you ran it as root and
had the filelists metadata cached then it would work.
Comment 2 Michael E Brown 2007-12-22 14:25:24 EST
Please test mock 0.8.19 which is currently in updates-testing. This issue was a
mock issue and should be fixed.
Comment 3 Ralf Corsepius 2007-12-22 21:59:14 EST
(In reply to comment #1)
> This is because you're running yum as non-root
Right.  This happens inside of mock, as part of running mock (== running yum as
non-root)

> If you ran it as root and
> had the filelists metadata cached then it would work.
A matter of point of view.

Fact is: /usr/bin/yum resolvedep (== a program to run by ordinary users)
resolvedep returns incorrect results.

Note You need to log in before you can comment on or make changes to this bug.