Bug 426575 - system-config-network hangs after loading network interfaces, but before starting GUI or TUI
system-config-network hangs after loading network interfaces, but before star...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 07:48 EST by Vedran Sego
Modified: 2008-04-22 18:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vedran Sego 2007-12-22 07:48:11 EST
Description of problem: When I start system-config-network (I've tried both -gui
and -tui), my CPU goes to 100% and stays there until i press Ctrl+C. When
started with -v -d, I get the following:
[3] Sat Dec 22 13:35:52 2007: Checking Desc:           nVidia Corporation MCP61
Ethernet
Driver:         forcedeth
Device:         eth0


Version-Release number of selected component (if applicable):
system-config-network-1.4.3-1.fc8


How reproducible: just start it. I'm not sure what causes this, so I cannot be
more precise, but I'm willing to provide more data on request.


Steps to Reproduce:
1. start system-config-network either from konsole as root or from menu
2. enter password (if started from menu)
  
Actual results:
3. die waiting ;-)


Expected results:
Obviously, I'd like app to start.


Additional info:

uname -a
Linux sime.styx.org 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:36 EST 2007 x86_64
x86_64 x86_64 GNU/Linux
Tried with the original F8 kernel (2.6.23.1-42.fc8) and one in between
(2.6.23.8-63.fc8). Version 2.6.23.8-63.fc8 didn't show modem in lspci, but
everything seemed to remained the same.

I have installed kmod-nvidia from Livna.

lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6100 nForce 430
(rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:08.0 Communication controller: Motorola SM56 PCI Modem

ifconfig
eth0      Link encap:Ethernet  HWaddr 00:19:66:30:10:BE  
          inet addr:192.168.100.6  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::219:66ff:fe30:10be/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:156 errors:0 dropped:0 overruns:0 frame:0
          TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:15446 (15.0 KiB)  TX bytes:9949 (9.7 KiB)
          Interrupt:252 Base address:0x6000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1057 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1057 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2865728 (2.7 MiB)  TX bytes:2865728 (2.7 MiB)

I want to install modem since this machine is being set up for a friend who
doesn't have access to DSL. I cannot remove modem from the machine, since it is
sealed (due to the terms of guarantee).
Comment 1 Vedran Sego 2007-12-22 11:28:18 EST
Ok, I've decided to go through all the Python code (though I don't know Pythin,
but its close enough to Perl, C, PHP,...) and I've traced the problem to
/etc/hosts loading. It seems that handling /etc/hosts entries is too time and
memory consuming. The problem occures in NCProfileList.py lines 143 through 151:
for key in hoconf.keys()...

I have a large /etc/hosts, most of it being taken from here:
http://www.mvps.org/winhelp2002/hosts.txt
Since this list is huge (around 600kB), hoconf list gets clogged with items and
this loop just goes on forever.

I don't need this large hosts file on this particular machine and have cropped
it to only few entries, but the problem persists on my other machine where I do
need large hosts file.

Workaround: replace /etc/hosts with something short (i.e. the one having only
localhost in it), do whatever you need to do with system-config-network and,
after you're done (and quit s-c-network), replace /etc/hosts with the original file.

Suggestion: it might be wise to move the handling of /etc/hosts to another app
or at least another window (being started from menus or with the click of the
button), since antispam hosts files are not that uncommon.
Comment 2 Jiri Moskovcak 2008-01-03 04:21:02 EST
Hi, this issue has been fixed in the 1.4.7 version of s-c-n. If you want to try 
it you can install it by $ yum update system-config-network --
enablerepo=updates-testing. But thanks to your hosts file i noticed a minor bug 
in this version - there is a problem on line 6423 it contains only hostname but 
no ip, so you have to edit the file manually and add 127.0.0.1 at the begging 
of that line.

Jirka
Comment 3 Fedora Update System 2008-04-07 10:34:35 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-04-09 01:19:54 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2995
Comment 5 Vedran Sego 2008-04-09 05:00:27 EDT
Ok, I've installed system-config-network-1.5.5-1.fc8 from F8 testing repository
and have tried it after updating my host file with enteries from
http://www.mvps.org/winhelp2002/hosts.txt .

Upon starting, s-c-n has reported errors in the following lines of the hosts file:
127.0.0.1  norbert_sirot.club.fr #[Trojan-Spy.Win32.Banker.anv]
127.0.0.1  ___id___.c.mystat-in.net #[Wildcard DNS]
127.0.0.1  web--search.com #[McAfee.Adware-SBSoft]
127.0.0.1  www.web--search.com
127.0.0.1  search_fd.php.coolwebsearch.com #[Wildcard DNS]

Now, underscore IS illegal part of domain/server name (at least SeaMonkey
doesn't recognize it), but minus (lines 3 and 4) is not. I see that only a
double-minus is not accepted (i.e. www2.a-counter.kiev.ua is not labeled as an
error), but since browsers accept double-minuses, I think s-c-n should as well
(to allow blacklisting). Actually, I don't see why s-c-n doesn't just ignore
this kind of errors (except when entries are edited through s-c-n itself).

What confused me more is that 127.0.0.1 entries from the hosts file were not
available for editing in s-c-n (didn't notice this before). I'm not sure if it's
considered a bug or a feature, but upon saving, errors persisted and were still
being reported, whith no way to repair them (inside s-c-n) and I do consider
this a problem: why reporting if I'm not given a way to repair it?

Minor note: upon saving, some lines had spaces (or tabs?) added at the end.
Comment 6 Jiri Moskovcak 2008-04-09 06:23:11 EDT
Yes, double minuses should be accepted - I'm going to fix this asap. But you 
not right about the 127.0.0.1 entries - there is a checkbox in the left lower 
corner called "show loopback" which toggles showing of this entries.

Jirka
Comment 7 Vedran Sego 2008-04-09 06:38:42 EDT
Sorry, I've missed that checkbox (I usually edit hosts file in gvim).

Related to that (although it's not a bug report): since error reports provide
line numbers, you might consider adding "line number" column to the GUI (new
enteries would have this field empty or set to "new" or something). With
something over 18000 lines in hosts file, reports like "error in line xxxxx" are
quite useless if you don't see the line numbers.

Thank you,

V.
Comment 8 Fedora Update System 2008-04-22 18:38:41 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.