Bug 426577 - OpenArena freezes every time I play it.
OpenArena freezes every time I play it.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openarena (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michał Bentkowski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 09:23 EST by Francesco
Modified: 2008-01-18 07:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 07:14:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (896 bytes, text/plain)
2008-01-01 16:55 EST, Francesco
no flags Details
xorg.log (19.04 KB, text/plain)
2008-01-01 16:55 EST, Francesco
no flags Details
output of: openarena 2> openarena_log (18.13 KB, text/plain)
2008-01-03 16:18 EST, Francesco
no flags Details

  None (edit)
Description Francesco 2007-12-22 09:23:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux 2.6.23.9-85.fc8; X11; i686; it) KHTML/3.5.8 (like Gecko)

Description of problem:
Every time I play OpenArena, after a while it freezes completely all the 
system, and I must hard reset the PC. I enabled the MagicSysRQ keys but they 
also don't respond.
I don't know how to get usefull information (core dumps, stack trace,...), the 
only think I know is that with Fedora8 I can't play OpenArena.
Quake3 have the same problem, instead other 3D programs like Google Earth for 
example works normally.
On my PC with Fedora7 OpenArena works well, the problem started with Fedora8.
I use nvidia 100.14.19 official driver from Livna.
My PC:
AthlonXP 2000
756MB RAM
GeForceFX 5600

Version-Release number of selected component (if applicable):
openarena-0.7.1-3.fc8

How reproducible:
Always


Steps to Reproduce:
1.Start OpenArena
2.Play for a while...
3.crash!

Actual Results:


Expected Results:


Additional info:
Comment 1 Michał Bentkowski 2007-12-31 15:50:50 EST
Would be nice if you could show me your /etc/X11/xorg.conf and /var/log/Xorg.0.log
files.
Comment 2 Francesco 2008-01-01 16:55:12 EST
Created attachment 290619 [details]
xorg.conf
Comment 3 Francesco 2008-01-01 16:55:43 EST
Created attachment 290620 [details]
xorg.log
Comment 4 Michał Bentkowski 2008-01-02 13:15:45 EST
Log doesn't report any problems. So please do the following in any directory
you have write access to:

  openarena 2> openarena_log

It will make your system freeze once again but write a possibly useful log
to openarena_log too. Then attach the log here please. Maybe it will help us
with finding out what causes the freeze.
Comment 5 Michał Bentkowski 2008-01-02 13:17:45 EST
And also you wrote that other 3D programs work. Have you tried to run e.g.
nexuiz, tenebrae, bzflag, csmash?
Comment 6 Francesco 2008-01-03 16:18:24 EST
Created attachment 290781 [details]
output of: openarena 2> openarena_log

I started OpenArena and like always it crashed after a little time, this is the
output.
I just play with Nexuiz for a while and it works normally, tomorrow I'll test
some other games.
I work whit this PC all the day and it's ok, I don't think about an hardware
failure.
Comment 7 Michał Bentkowski 2008-01-04 15:17:52 EST
I see nothing wrong in any file you've attached...
It seems you have to test as many applications as possible. Try whether
tremulous works good since it's quake3 engine too. If it makes the system 
freeze, we could guess that's just q3-related.

However, I'm afraid it could have something to do with your hardware even if
you are able to work with it without problems. This is due to non-3d apps don't
require much of resources. 3d apps do and then something just crashes. It's just
a hypothesis and may or may not be true. It could be also related to nvidia
drivers and be a problem specifically with your GeForce 5600 gpu. 

To summarize: you should check whether tremulous works. If it doesn't, maybe
trying to downgrade nv drivers would be worthwhile.
If nothing helps, we'll have to think on...
Comment 8 Francesco 2008-01-18 07:14:43 EST
I make some tests:
Goggle Earth, Nexuiz and BZFlags works well and never crash, the only games 
than crash are Tremulous, OpenArena and Quake3.
I tried with nvidia 169.07 and also 96.43, but neither solve the problem.

So I installed Fedora on another partition and try OpenArena, and it doesn't 
crash.
Probably there is something wrong in the configuration of the previous Fedora, 
but it's strange because I don't remember to change something.

Note You need to log in before you can comment on or make changes to this bug.