Bug 426587 - Renaming translation po file from sr@Latn to sr@latin
Renaming translation po file from sr@Latn to sr@latin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hwbrowser (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 12:40 EST by Miloš Komarčević
Modified: 2007-12-27 07:26 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-27 07:26:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miloš Komarčević 2007-12-22 12:40:01 EST
+++ This bug was initially created as a clone of Bug #312431 +++

Please rename the po file sr@Latn to sr@latin in VCS as the locale label has
changed in glibc recently. Any Makefiles etc. should be updated to reflect the
change as well.
Comment 1 Nils Philippsen 2007-12-24 05:07:42 EST
Milos, do you have references (glibc) for me where I can read about the
background of this change? Is there a transition phase where both sr@Latn and
sr@latin would give you the same locale?
Comment 2 Miloš Komarčević 2007-12-25 14:29:01 EST
Nils, please refer to the following request in glibc bugzilla:

http://sources.redhat.com/bugzilla/show_bug.cgi?id=3322

Incidentally, @Latn (ISO code suggested by Gnome devs a while ago) never existed
in glibc as Ulrich would only accept @latin (follow the threads in [1,2] if
you're interested in the background), so we were forced into a slow transition
process now. Since it never existed in glibc, I don't think it is necessary to
support both. I have requested aliases in X locales so things should mostly just
work:

https://bugs.freedesktop.org/show_bug.cgi?id=11456

We would however very much like to move everything over for F9 and RHEL6.

[1] http://sourceware.org/ml/libc-alpha/2003-09/msg00225.html
[2] http://sourceware.org/ml/libc-alpha/2004-01/msg00144.html
Comment 3 Nils Philippsen 2007-12-27 07:26:39 EST
fixed in hwbrowser-0.41

Note You need to log in before you can comment on or make changes to this bug.