Bug 426620 - Yum cleanup phase apears confused
Yum cleanup phase apears confused
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 21:54 EST by Tobias Oed
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 12:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full yum output (104.10 KB, application/octet-stream)
2007-12-22 21:54 EST, Tobias Oed
no flags Details

  None (edit)
Description Tobias Oed 2007-12-22 21:54:37 EST
Description of problem:
Running a yum update, I get these errors for every package (full yum output in
attached file)
  Updating  : perl-Test-Simple             ##################### [214/420] 
  Cleanup   : pam-devel                    ##################### [215/420] 
  Cleanup   : mysql-libs                   ##################### [216/420] 
ts_done name in te is wine should be mysql-libs
  Cleanup   : wine-core                    ##################### [217/420] 
ts_done name in te is mysql-libs should be wine-core
  Cleanup   : gnome-desktop                ##################### [218/420] 
ts_done name in te is wine-core should be gnome-desktop
  Cleanup   : elfutils-libelf              ##################### [219/420] 
ts_done name in te is gnome-desktop should be elfutils-libelf
  Cleanup   : system-config-printer        ##################### [220/420] 
ts_done name in te is elfutils-libelf should be system-config-printer

etc...

Version-Release number of selected component (if applicable):
I was running yum.noarch 3.2.4-2.fc7 and it upgraded itself 
to  yum - 3.2.8-2.fc7.noarch

How reproducible:
Not sure actually, since I can't run the update again. I saw something similar
before, but I think it was about postrun scrips using the name of the previous
package. Left a nice mess that time too

Steps to Reproduce:
1. yum update
  
Actual results:
The cleanup phase cleans the previous package not the one it's working on

Expected results:
The cleanup phase cleans the package it's working on, not the previous one


Additional info:
This is a huge update 500Mb, 200 packages
Tobias
Comment 1 Tobias Oed 2007-12-22 21:54:37 EST
Created attachment 290302 [details]
full yum output
Comment 2 Seth Vidal 2008-03-12 12:10:33 EDT
The problem is an error in one of the pkgs in the transaction that's only 'sort
of' reported. However, we've quieted the noise and the transaction shouldn't be
adversely impacted, now.

Note You need to log in before you can comment on or make changes to this bug.