Bug 426655 - rt61pci WiFi module loosing connection
rt61pci WiFi module loosing connection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 17:34 EST by Milan Kerslager
Modified: 2008-01-30 11:30 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.23.14-115.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 11:30:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2007-12-23 17:34:24 EST
Latest kernels are loosing connection via my RaLink RT2561/RT61 802.11g PCI
card. The connection is established and my client is associated with AP but
after a random time, the connection is down even iwconfig still reports that
wlan0 interface is still autenthicated.

Latest working kernel is kernel-2.6.23.1-42.fc8.
Current kernel is 85, but does not work and 63 and 49 does not work too.

The kernel output:

wlan0: No ProbeResp from current AP 00:0b:6b:56:11:96 - assume out of range
wlan0: No STA entry for own AP 00:0b:6b:56:11:96
wlan0: RX deauthentication from 00:0b:6b:56:11:96 (reason=2)
wlan0: deauthenticated
wlan0: authenticate with AP 00:0b:6b:56:11:96
wlan0: authenticate with AP 00:0b:6b:56:11:96
wlan0: authenticate with AP 00:0b:6b:56:11:96
wlan0: authentication with AP 00:0b:6b:56:11:96 timed out
wlan0: authentication frame received from 00:0b:6b:56:11:96, but not in
authenticate state - ignored
wlan0: authentication frame received from 00:0b:6b:56:11:96, but not in
authenticate state - ignored
wlan0: authentication frame received from 00:0b:6b:56:11:96, but not in
authenticate state - ignored

...and the connection is not working anymore. When network is restarted, the
connection works again until the same problem repeates.
Comment 1 Milan Kerslager 2007-12-25 03:58:19 EST
Kernel kernel-2.6.23.1-42.fc8 looses connection too.
I would like to try older kernels but I don't know where to grab them :-(
Comment 2 Wojciech Kazubski 2007-12-29 17:00:52 EST
Looks like bug 419871 ...
Does the driver use new mac80211 stack?
Comment 3 John W. Linville 2008-01-23 14:26:32 EST
Please try the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=31896

Can you recreate the problem using these kernels?
Comment 4 Milan Kerslager 2008-01-23 14:43:41 EST
I have no problem so far since 2.6.23.12-99.fc8. I'll try to use
kernel-2.6.23.14-111.fc8 (or later) and report back if the problem reoccur.
Comment 5 Milan Kerslager 2008-01-23 15:06:40 EST
To be more precise - with 99 kernel, the connection probably has been lost and
the driver reconnect silently because my SSH connections freezes sometimes, but
there were no messages from the kernel (dmesg).
Now I have 111 kernel and will try to test & report.
Comment 6 Milan Kerslager 2008-01-23 15:09:49 EST
There is (probably) another bug - iwconfig reports 1Mbps link even actual
transfer rate is around 3 Mbps on wlan0 interface (as reported by iptraf).
Should I report this issue separately or this is a side effect of transition to
the new stack?
Comment 7 Chuck Ebbert 2008-01-23 15:27:39 EST
kernel -115 is being sent to the updates-testing repo. Please test that one.
Comment 8 Milan Kerslager 2008-01-30 11:22:23 EST
I have 115 kernel since Jan 23 and I did not experienced any problem mentioned
above. This is at home so the testing is not whole-day but evenings only.
Comment 9 Christopher Brown 2008-01-30 11:30:05 EST
Milan,

Will close as such but please re-open if it re-occurs.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.