Bug 426671 - mkinitrd creates an unbootable system when fstab contains label=volumelabel and volumes are lvm
mkinitrd creates an unbootable system when fstab contains label=volumelabel a...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-23 23:07 EST by saul
Modified: 2008-07-21 16:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: fc9, mkinitrd-6.0.52-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 16:24:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fstab with device names (693 bytes, application/octet-stream)
2007-12-23 23:12 EST, saul
no flags Details
sh -x output of mkinitrd run using fstab with device names (403.37 KB, application/octet-stream)
2007-12-23 23:13 EST, saul
no flags Details
fstab using volume labels (655 bytes, application/octet-stream)
2007-12-23 23:13 EST, saul
no flags Details
sh -x output of mkinitrd run using fstab using labels (324.35 KB, application/octet-stream)
2007-12-23 23:14 EST, saul
no flags Details

  None (edit)
Description saul 2007-12-23 23:07:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Description of problem:
When I use an fstab that mounts root with a label=root in the first field, and
root is on a logical volume which is, in turn, on a raid volume,
mkinitrd creates an initrd that doesn't seem to include raid or lvm,
either as modules or in the nash script to active raid and the volume
groups.

An equivalent fstab that references devices produces a valid initrd.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.19-4.fc8

How reproducible:
Always


Steps to Reproduce:
1.Build an fstab with label=volumelabel
2.mkinitrd
3.boot

Actual Results:
System doesn't boot

Expected Results:
System should have booted

Additional info:
This may be related, or the same bug as:

https://bugzilla.redhat.com/show_bug.cgi?id=241949

This problem, or one quite like it, occurred in Fedora Core 7, and the patch
in bug 241949 made mkinitrd work for me. mkinitrd has changed sufficiently
since FC7 that reapplying the patch is not straighforward.
Comment 1 saul 2007-12-23 23:12:19 EST
Created attachment 290334 [details]
fstab with device names
Comment 2 saul 2007-12-23 23:13:30 EST
Created attachment 290335 [details]
sh -x output of mkinitrd run using fstab with device names
Comment 3 saul 2007-12-23 23:13:55 EST
Created attachment 290336 [details]
fstab using volume labels
Comment 4 saul 2007-12-23 23:14:40 EST
Created attachment 290337 [details]
sh -x output of mkinitrd run using fstab using labels
Comment 5 Rubin Simons 2008-04-23 10:34:28 EDT
I can confirm this bug still exists in RHEL 4 ES U5. I ran into it last week;
specify root as "LABEL=/" in /etc/fstab; watch mkinitrd skip lvm-specific steps
like copying {lvm.static, lvm.conf} and including more than only the dm-mod
module. It seems to me that bugs #209473, #212124, #214184, #246626, #294051 and
#327181 are related to this (not sure if they're strictly dupes).
Comment 6 Andy Lindeberg 2008-07-14 17:23:08 EDT
Are you still encountering this in F9?
Comment 7 saul 2008-07-14 23:46:05 EDT
(In reply to comment #6)
> Are you still encountering this in F9?

I haven't been able to do a full test (a reboot), but a quick look at a newly
generated initrd makes me hopeful that this has been fixed. 

I'll be able to confirm that in the next day or two. 

Thanks for checking in.
Comment 8 saul 2008-07-21 16:24:57 EDT
I've done a test reboot and this seems to be working fine now, on
Fedora 9, using mkinitrd-6.0.52-2.fc9. Thanks for following up.

Note You need to log in before you can comment on or make changes to this bug.