Bug 426688 - NM fails to merge identical AP entries
NM fails to merge identical AP entries
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 07:10 EST by Ignacio Vazquez-Abrams
Modified: 2008-01-12 23:19 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.7.0-0.6.7.svn3235.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-12 23:19:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2007-12-24 07:10:41 EST
NetworkManager-0.7.0-0.6.6.svn3138.fc8
wpa_supplicant-0.5.7-19.fc8

Currently nm-tool reports the following, where "xx..." indicates entries I care
about, and "yy..." entries I don't:

  Wireless Access Points(* = Current AP)
    xxxxxx:          Infra, 00:00:00:00:00:00, Freq 0 MHz, Rate 0 Mb/s, Strength 0
    yyyyyy:          Infra, 00:19:yy:yy:yy:yy, Freq 2437 MHz, Rate 54 Mb/s,
Strength 43 WEP
    *xxxxxx:         Infra, 00:13:xx:xx:xx:xx, Freq 2412 MHz, Rate 54 Mb/s,
Strength 87

To the untrained observer, the first and third entries are clearly the same
since a) they share the same ESSID, and b) none of the values in the first entry
other than the ESSID (and the strength, if you happen to have a broken WLAM
driver) are valid.

Even better is when the following happens:
  Wireless Access Points(* = Current AP)
    *<hidden>:       Infra, 00:13:xx:xx:xx:xx, Freq 2412 MHz, Rate 54 Mb/s,
Strength 87
    xxxxxx:          Infra, 00:00:00:00:00:00, Freq 0 MHz, Rate 0 Mb/s, Strength 0
    yyyyyy:          Infra, 00:19:yy:yy:yy:yy, Freq 2437 MHz, Rate 54 Mb/s,
Strength 43 WEP
    *xxxxxx:         Infra, 00:13:xx:xx:xx:xx, Freq 2412 MHz, Rate 54 Mb/s,
Strength 87

In this case the first, second, and fourth entries are the same and should be
merged.

/etc/wpa_supplicant/wpa_supplicant.conf:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=2
network={
  ssid="xxxxxx"
  key-mgmt=NONE
  scan_ssid=1
}
Comment 1 Ignacio Vazquez-Abrams 2008-01-12 23:19:49 EST
All of the sudden it seems to have disappeared.

Note You need to log in before you can comment on or make changes to this bug.