Bug 426713 - rpm conflict with php-eaccelerator
rpm conflict with php-eaccelerator
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php-pecl-apc (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Chris Chabot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 14:23 EST by John Ellson
Modified: 2009-01-04 17:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-04 17:32:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2007-12-24 14:23:38 EST
Description of problem:
rpm conflict with php-eaccelerator

Version-Release number of selected component (if applicable):
php-pecl-apc-0:3.0.14-2.fc8.x86_64 
php-eaccelerator-0.9.5.2-1.fc9.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum install php-pecl-apc
2.
3.
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package php-pecl-apc.x86_64 0:3.0.14-2.fc8 set to be updated
--> Processing Conflict: php-pecl-apc conflicts php-eaccelerator
--> Finished Dependency Resolution
Error: php-pecl-apc conflicts with php-eaccelerator


Expected results:
no conflicts

Additional info:
Comment 1 Bug Zapper 2008-05-14 00:14:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tim Jackson 2008-06-26 04:20:06 EDT
I assume that was deliberate on the part of the maintainer since I suspect
loading both APC and eAccelerator won't work.
Comment 3 Chris Chabot 2008-07-13 08:27:07 EDT
Your correct in your assumptions tim.

If you yum install them both, both are enabled by default so php tries to load
both opcode cache modules, which results in disaster.

The simplest way to protect users from this was to add a conflict rule..

I thought in the end it was easier to yum remove apc / yum install eAccelerator
and visa versa, then hope everyone knows which /etc/php.d/*.conf files to edit
to get to a working situation.

Note You need to log in before you can comment on or make changes to this bug.