Bug 426714 - fc9 tagged kernels cause network service to stall system, fc8 tagged .. no stall
fc9 tagged kernels cause network service to stall system, fc8 tagged .. no stall
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 14:44 EST by Jim Cornette
Modified: 2008-02-14 06:16 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.25-0.35.rc1.fc9.i686
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 06:16:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My Ethernet Card ifup script which is used for system (176 bytes, text/plain)
2007-12-24 14:44 EST, Jim Cornette
no flags Details
ps axf after network service started (4.44 KB, text/plain)
2008-01-07 18:22 EST, Jim Cornette
no flags Details
ps axf for fc8 tagged kernel (4.71 KB, text/plain)
2008-01-07 22:18 EST, Jim Cornette
no flags Details
ps axf when connected (7.62 KB, text/plain)
2008-01-27 15:28 EST, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2007-12-24 14:44:26 EST
Description of problem:
When either starting in runlevel 1 followed by changing to either rl3 or rl5 the
system freezes after network OK. With kernels tagged fc8 network services starts
normally. The system also hangs starting originally with either rl3 or rl5
Also, if network disabled, a lockup in the system happens if in rl1. This was
also tried with failure encountered.

Version-Release number of selected component (if applicable):
initscripts-8.60-1
kernel-2.6.23.8-63.fc8 - network starts normally
kernel-2.6.24-0.123.rc6.fc9 - network locks up

How reproducible:
Boot with network service in either rl3 or rl5 using any kernel tagged fc9. See
system freeze in either runlevel.

Steps to Reproduce:
1. enable network at start
2.boot with fc9 tagged kernel
3. control-c when /dev/rtc tried to be created
4. wait after network OK for a long period of time
  
Actual results:
notice network said started OK but system does not advance

Expected results:

System to initialize without a lockup or stall

Additional info:

With network services off and instead using NetworkManager the system boots up
except for the /dev/rtc and /dev/rtc0 created error. After booting into GNOME I
can access network without error.
Comment 1 Jim Cornette 2007-12-24 14:44:26 EST
Created attachment 290357 [details]
My Ethernet Card ifup script which is used for system
Comment 2 Jim Cornette 2008-01-03 19:16:04 EST
Problem still exists
kernel-2.6.23.9-85.fc8 - network starts OK
kernel-2.6.24-0.133.rc6.git8.fc9 - locks up after network is started and replies OK
Comment 3 Bill Nottingham 2008-01-07 14:49:12 EST
Is the system completely hung, or is just the startup process hung?

If you boot with 'confirm' and choose to not set up the network, does it hang if
you start it by hand?
Comment 4 Jim Cornette 2008-01-07 17:22:58 EST
I believe it is the startup process. I can change from the GUI rhgb screen to
screen 1 text.
It locks up if you start network after the system is ready also. If network
services are not launched automatically and networkmanager is used I have
connectivity plus wireless with fc9 tagged kernels. Both service network start
and metworkmanager work with fc8 kernels which I tried with no problem. (not
both on at the same time, used individully)
Comment 5 Bill Nottingham 2008-01-07 17:27:52 EST
Can you do 'service network start' on one terminal, wait for the hang, and do
'ps axf' on the other terminal (and capture the output?)
Comment 6 Jim Cornette 2008-01-07 18:22:29 EST
Created attachment 291026 [details]
ps axf after network service started

Yes it was possible to start the network service from one vt in runlevel 3
while able to use a second vt to save process information. I saved the output
before starting network too but did not add it to the report.
Comment 7 Jim Cornette 2008-01-07 18:27:52 EST
Using kernel-2.6.24-0.138.rc7.fc9 for test.
Comment 8 Jim Cornette 2008-01-07 21:51:56 EST
Looking through the attachment it looks like eth1 is trying to be initialized.
It is a wireless PCMCIA card that is not supposed to be started at boot. I have
no wireless modem so my neighbors networks are seen but are not used so the card
should not be initialized on boot.

eth1:
cat /etc/sysconfig/network-scripts/ifcfg-eth1
# Cisco Systems 350 Series Wireless LAN Adapter
DEVICE=eth1
BOOTPROTO=dhcp
ONBOOT=no
HWADDR=00:0e:38:c7:bc:10
[root@HP-JCF7 ~]# cat /etc/sysconfig/networking/devices/ifcfg-eth1
# Cisco Systems 350 Series Wireless LAN Adapter
DEVICE=eth1
ONBOOT=no
BOOTPROTO=dhcp
HWADDR=00:0e:38:c7:bc:10
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
TYPE=Wireless
USERCTL=no
IPV6INIT=no
PEERDNS=yes
ESSID=
CHANNEL=1
MODE=Master
RATE=Auto

Tcat /etc/sysconfig/network-scripts/ifcfg-eth0
# National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:0B:CD:34:B0:16
ONBOOT=yes
DHCP_HOSTNAME=HP-JCF7
TYPE=Ethernet
[root@HP-JCF7 ~]# cat /etc/sysconfig/networking/devices/ifcfg-eth0
# National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:0B:CD:34:B0:16
ONBOOT=yes
DHCP_HOSTNAME=HP-JCF7
TYPE=Ethernet
 This is the card that I want below which happens for the fc8 tagged but
apparently not for fc9 tagged versions, if I'm reading the information correctly.

eth0:
cat /etc/sysconfig/network-scripts/ifcfg-eth0
# National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:0B:CD:34:B0:16
ONBOOT=yes
DHCP_HOSTNAME=HP-JCF7
TYPE=Ethernet
[root@HP-JCF7 ~]# cat /etc/sysconfig/networking/devices/ifcfg-eth0
# National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:0B:CD:34:B0:16
ONBOOT=yes
DHCP_HOSTNAME=HP-JCF7
TYPE=Ethernet

Comment 9 Bill Nottingham 2008-01-07 22:17:21 EST
 1161 ?        D<     0:00 /sbin/modprobe
pcmcia:m015Fc000Af06fn00pfn00paA17C320Epb3D011600pc00000000pd00000000

This command is hanging - this is a kernel issue (presumably in that driver.)
Comment 10 Jim Cornette 2008-01-07 22:18:53 EST
Created attachment 291035 [details]
ps axf for fc8 tagged kernel

The system was brought up with network services initially off for startup. I
logged into two vt terminals and comparatively repeated the same procedures
that I tried for the previous fc9 tagged kernel. This kernel is kernel version
2.6.23.9-85.fc8 which seems to work as expected.
Comment 11 Jim Cornette 2008-01-07 22:28:10 EST
Thanks! So the unused at home wireless card is causing the hang? Should I file a
bug against the kernel and driver or redirect this bug report to the pcmcia
wireless driver?
Comment 12 Bill Nottingham 2008-01-08 00:39:06 EST
This is already moved to the kernel - no new bug required.
Comment 13 Jim Cornette 2008-01-20 22:09:39 EST
The network does not stall when using kernel-2.6.23.14-107.fc8 but still does
for kernel-2.6.24-0.157.rc8.fc9.
Was there a major change in 2.6.24 from 2.6.23 which accounts for the service
network start problem that I'm currently stuck with?
Comment 14 Jim Cornette 2008-01-26 13:08:00 EST
Cisco Aironet wireless PCMCIA adapter seems to be the identity of the driver
causing the lockup according to Chuck Ebbert from a mailing list posting.
Comment 15 Jim Cornette 2008-01-27 15:28:27 EST
Created attachment 293084 [details]
ps axf when connected

It appears that I can still connect to the network.
I am in runlevel 3 and started network services which hung but seemed to
connect my wired connection fine.
Comment 16 Jim Cornette 2008-02-14 06:16:24 EST
With kernel-2.6.25-0.35.rc1.fc9.i686 the lockup at starting network services is
no longer a problem. I do get a wired connection. The wireless driver will be
examined later which caused the initial service network start lockup with kernel
2.6.24 series kernels.

Note You need to log in before you can comment on or make changes to this bug.