Bug 426761 - ntpq man page is mangled (generally: ntp man pages are old!)
ntpq man page is mangled (generally: ntp man pages are old!)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ntp (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Miroslav Lichvar
Brian Brock
:
: 426745 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-25 19:31 EST by David Tonhofer
Modified: 2008-07-24 15:34 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0678
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2007-12-25 19:31:25 EST
Description of problem:

"man ntpq" shows, starting from

"peers   Obtains a current list peers of the server"

a list of "fates" of the peers: space, x, ., -. +, # ....

1) The list should be indented
2) The 'fate' character should be separated from the word indicating semantics
3) The '.' character representing the 'discarded' fate is not shown at all

The manpages come in the tarball "ntp-4.2.0-rh-manpages.tar.gz" of the NTP
source package. Compare with the html pages in the "ntp-stable-4.2.0a-20040617"
subdirectory of the source packages:

cd /usr/src/redhat/SOURCES
elinks ntp-stable-4.2.0a-20040617/html/ntpq.html
  vs
less man/ntpq.1

Weirdly, the text of the man page does not match the text of the html page.
The latter corresponds more or less to the current man page at
http://www.eecis.udel.edu/~mills/ntp/html/ntpq.html 
but the ntpq man page corresponds to ntp 4.1.1b-r5. 

Needs an update.
Comment 1 RHEL Product and Program Management 2008-01-02 07:15:08 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Miroslav Lichvar 2008-01-24 06:06:34 EST
*** Bug 426745 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2008-07-24 15:34:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0678.html

Note You need to log in before you can comment on or make changes to this bug.