Bug 426764 - no sound (on KDE)
no sound (on KDE)
Status: CLOSED DUPLICATE of bug 426275
Product: Fedora
Classification: Fedora
Component: quake3 (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-25 21:07 EST by Philip Ashmore
Modified: 2008-01-02 04:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 09:13:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Ashmore 2007-12-25 21:07:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
The default install results in no sound output in KDE.
I haven't tried it on Gnome.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.# yum -y install quake3
2.$ quake3
3.

Actual Results:
The game works fine, but no sound.

Expected Results:
Sound and graphics.

Additional info:
------- sound initialization -------
/dev/dsp: Device or resource busy
Could not open /dev/dsp
------------------------------------
Sound memory manager started
Comment 1 Hans de Goede 2007-12-27 06:14:52 EST
This might be a dup of bug 426275.

Please try running yum update to get the fix for this bug and try again.

If that doesn't work:
Have you done a default F-8 install? Normally you should be using pulseaudio,
so you should have a pulseaudio process in your "ps aux".

Note for me it says the following at startup:
------ Initializing Sound ------
Initializing SDL audio driver...
SDL audio driver is "esd".
SDL_AudioSpec:
  Format:   AUDIO_S16LSB
  Freq:     22050
  Samples:  512
  Channels: 2
Starting SDL audio callback...
SDL audio initialized.
----- Sound Info -----
    1 stereo
16384 samples
   16 samplebits
    1 submission_chunk
22050 speed
0x14e6dd0 dma buffer
No background file.
----------------------
Sound initialization successful.
--------------------------------

Can you please copy and paste your full sound init output, especially
interesting are these 2 lines:

Initializing SDL audio driver...
SDL audio driver is "esd".

Comment 2 Philip Ashmore 2007-12-30 08:57:26 EST
I also reported https://bugzilla.redhat.com/show_bug.cgi?id=417761
and the solution there was...

    "You could consider disabling pulseaudio support in kde, via:
    yum remove kde-settings-pulseaudio alsa-plugins-pulseaudio"

...which I did.

# ps aux|grep [p]ulseaudio

yields no results.
Comment 3 Hans de Goede 2007-12-31 09:13:22 EST
Okay, I managed to reproduce this by disabling pulseaudio, this indeed is a dup
of bug 426275. Closing as such.

To fix it, run yum update (as I already asked you todo, just as I asked for the
relevant quake3 output, next time please follow instructions better when asked
for info), logout out and in again, and then it should work.


*** This bug has been marked as a duplicate of 426275 ***
Comment 4 Philip Ashmore 2007-12-31 15:55:26 EST
We seem to be both talking about fruit while I'm looking at an apple, and you
are looking at a pear!

1. my F8 install is from the KDE live image : alsa+pulseaudio but no esd.
2. I disabled pulseaudio as indicated above.
3. I run yum update almost daily.
4. I downloaded and installed linuxq3apoint-1.32.x86.run
5. I then copied over the executables from quake3-1.32c-linux.zip
6. I then ran "yum -y install quake3"
7. Finally I copied the pak0.pk3 from the Q3A disc to /usr/local/games/quake3/baseq3

The output I get is the same as the "additional info" accompanying my initial
bug report - 
    ------- sound initialization -------
    /dev/dsp: Device or resource busy
    Could not open /dev/dsp
    ------------------------------------
    Sound memory manager started

Mine starts with "sound initialization" while yours starts with "Initializing
Sound" - I'm cutting and pasting from konsole here.

Something tells me we're looking at different fruit!
Comment 5 Hans de Goede 2007-12-31 16:36:21 EST
It seems you are using an ancient quake3 binary from ID software??

This bug tracker is for the Fedora package of quake3, which is a package of the
modern SDL using ioquake3 quake3 engine.

Please move your pak0.pk3 and the other pak?.pk3 files from the point release to
/usr/share/quake3/baseq3

And then run /usr/bin/quake3, which should be the ioquake3 binary.
Comment 6 Philip Ashmore 2008-01-01 21:11:03 EST
1. I never knew about ioquake3 before reading your post.
I just downloaded and installed it - it worked right out of the box as
"ioquake3" - perhaps the quake3 RPM should make explicit reference to it in it's
description.

2.  $ rpm -qi quake3
makes mention of "an applications menu entry, which will offer to download and
install the Quake 3 demo datafiles for you" - I see no such menu entry in KDE.

3. On my installation the pk3 files need to go to /usr/local/games/ioquake3/baseq3/

Thanks.
Comment 7 Hans de Goede 2008-01-02 04:33:02 EST
(In reply to comment #6)
> 1. I never knew about ioquake3 before reading your post.
> I just downloaded and installed it - it worked right out of the box as
> "ioquake3" - perhaps the quake3 RPM should make explicit reference to it in it's
> description.
> 

The Fedora quake3 package contains ioquake3, so there was no need to install it,
again please follow instructions, executing /usr/bin/quake3 propably would have
gotten you the ioquake3 that is part of the quake3 package. Before that you were
most likely using the older quake binary included in the
linuxq3apoint-1.32.x86.run, which you installed on your own account. You've made
a mess of things by installing 3 different quake's by now:
1) the original ID software quake3 binary from linuxq3apoint-1.32.x86.run
2) the fedora compiled ioquake3 version from the quake3 package
3) some kind of generic ioquake3 from who knows where

> 2.  $ rpm -qi quake3
> makes mention of "an applications menu entry, which will offer to download and
> install the Quake 3 demo datafiles for you" - I see no such menu entry in KDE.
> 

Works fine for me.

> 3. On my installation the pk3 files need to go to
/usr/local/games/ioquake3/baseq3/
> 

Because you are not using the Fedora quake3 version.

Note You need to log in before you can comment on or make changes to this bug.