Bug 426839 - Syntax error in system-config-cluster FaildomController.py
Syntax error in system-config-cluster FaildomController.py
Status: CLOSED DUPLICATE of bug 398291
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-27 02:08 EST by Wade Mealing
Modified: 2009-04-16 16:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 15:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to correct error. (572 bytes, text/x-patch)
2007-12-27 02:08 EST, Wade Mealing
no flags Details

  None (edit)
Description Wade Mealing 2007-12-27 02:08:00 EST
Version:

system-config-cluster-1.0.51-2.0.noarch.rpm


When launching system-config-cluster the error is shown.
system-config-cluster 
Traceback (most recent call last):
  File "/usr/sbin/system-config-cluster", line 52, in <module>
    from ConfigTab import ConfigTab
  File "/usr/share/system-config-cluster/ConfigTab.py", line 27, in <module>
    from ConfigTabController import ConfigTabController
  File "/usr/share/system-config-cluster/ConfigTabController.py", line 35, in
<module>
    from FaildomController import FaildomController
  File "/usr/share/system-config-cluster/FaildomController.py", line 213
    if val == "Yes" or val == "yes" or val="1":
                                          ^
SyntaxError: invalid syntax


I believe this should be:


if val == "Yes" or val == "yes" or val=="1": 

Additional info:

Patch incoming.
Comment 1 Wade Mealing 2007-12-27 02:08:00 EST
Created attachment 290438 [details]
Patch to correct error.
Comment 2 Jim Parsons 2008-01-30 15:41:49 EST
This is fixed and a z-stream release is on the way.

*** This bug has been marked as a duplicate of 398291 ***

Note You need to log in before you can comment on or make changes to this bug.