This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 426872 - NetworkManager: <WARN> connection_state_changed(): Could not process the request because no VPN connection was active.
NetworkManager: <WARN> connection_state_changed(): Could not process the req...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-27 14:30 EST by Eric Paris
Modified: 2008-01-27 06:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 06:03:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2007-12-27 14:30:16 EST
Description of problem:

I cannot get NetworkManager-vpnc to connect to my vpn.  I have never been able
to get nm-vpnc to work since installing F8 some time back (it was working back
when I used F7)  I have been connecting by directly running vpnc and putting my
info in /etc/vpnc/default.conf

I created a new vpn connection.  When I try to launch it the first time it
brought up the box asking for my password and group id.  I enter both and told
it to store them in the keyring.  Checking in the keyring I am able to see that
the passwords are correct.  Now every time I try to start vpnc I get:


Dec 27 14:28:12 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' exec scheduled...
Dec 27 14:28:12 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' executed
(org.freedesktop.NetworkManager.vpnc), PID 3911
Dec 27 14:28:12 localhost NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Dec 27 14:28:12 localhost NetworkManager: <info>  VPN connection 'RedHat'
(Connect) reply received.
Dec 27 14:28:12 localhost kernel: tun0: Disabled Privacy Extensions
Dec 27 14:28:13 localhost NetworkManager: <WARN>  connection_state_changed():
Could not process the request because no VPN connection was active.

NetworkManager-openvpn-0.7.0-2.svn3047.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3138.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8
NetworkManager-0.7.0-0.6.6.svn3138.fc8
Comment 1 Colin Walters 2008-01-03 15:34:53 EST
I see this as well.

One note is that there is no process with the PID specified in the log (perhaps
it's crashing?)
Comment 2 Ariel C 2008-01-17 21:04:11 EST
I'm seeing the same thing:

Jan 17 16:38:18 fedora NetworkManager: <WARN>  connection_state_changed(): Could
not process the request because no VPN connection was active.

I get this error only when using the networkmanager-vpnc tool.  As soon as I
click on the nm-applet > vpn connections > vpn_profile, the orange comet swirls
around the nm-applet for about 2 seconds then just stops and nothing happens.  I
don't get prompted for a username/password.  Only the error posted above gets
logged.

If I use vpnc via command line, that works perfectly fine.


[root@fedora mozilla]# uname -a
Linux fedora 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686 i686 i386
GNU/Linux



NetworkManager-0.7.0-0.6.6.svn3138.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8


vpnc-0.5.1-2.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8


# lspci |grep -i ether
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
Comment 3 Eric Paris 2008-01-26 17:13:54 EST
well, i found my problem, my local username is paris but my vpn username is
eparis.  I went into the config program added the username override and
NetworkManager-vpnc started working.

If this is everyone else's problem this bugzilla should be changed to instead
have some, even minimally useful, error reporting.  A pop up bubble that says
something, anything....
Comment 4 Denis Leroy 2008-01-27 06:03:06 EST
Good to hear, and the other problem reported here sounds like a duplicate of
331141 or 429287, so I'm going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.