Bug 426928 - (TBb2a27cb7) TBb2a27cb7 NCHardwareList.py:361:updateFromKudzu:NameError: global name '_HardwareList__isdnmodulelist' is not defined
TBb2a27cb7 NCHardwareList.py:361:updateFromKudzu:NameError: global name '_Har...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 427797 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-28 10:27 EST by Miroslav Pragl
Modified: 2008-04-22 18:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Pragl 2007-12-28 10:27:11 EST
Description of problem:
I use http://userweb.kernel.org/~jikos/ipwireless_cs/ driver for my mobile
connection. It causes crash of system-config-network* applet (both X and console
version)

Version-Release number of selected component (if applicable):
system-config-network 1.4.3

How reproducible:
100%

Steps to Reproduce:
1. compile ipwireless_cs
2. modprobe ipwireless_cs
3. system-config-network -> crashes
  
Actual results:
Component: system-config-network
Version: 1.4.3
Summary: TBb2a27cb7 NCHardwareList.py:361:updateFromKudzu:NameError: global name
'_HardwareList__isdnmodulelist' is not defined

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
277, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
289, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
780, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
635, in load
    self.updateFromSystem()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
473, in updateFromSystem
    self.updateFromKudzu()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
361, in updateFromKudzu
    if (kudzu_device.driver + '.o' in __isdnmodulelist) or \
NameError: global name '_HardwareList__isdnmodulelist' is not defined

Local variables in innermost frame:
ethlist: ['lo', 'wmaster0', 'wlan0', 'eth0']
kudzu: <module 'kudzu' from '/usr/lib/python2.5/site-packages/kudzu.pyc'>
self: 
hdellist: []
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 0x96cbc4c>
kudzu_device: Desc:           IPWireless 3G Data Modem V2
Driver:         ipwireless_cs
Device:         None

kudzulist: [Desc:           IPWireless 3G Data Modem V2
Driver:         ipwireless_cs
Device:         None
, Desc:           Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express
Driver:         tg3
Device:         eth0
, Desc:           Intel Corporation PRO/Wireless 3945ABG Network Connection
Driver:         iwl3945
Device:         wlan0
]



Expected results:
just want it run

Additional info:
Comment 1 Johan Kok 2008-01-13 15:21:06 EST
*** Bug 427797 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2008-04-07 10:34:48 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-04-09 01:20:08 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2995
Comment 4 Fedora Update System 2008-04-22 18:38:55 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.