Bug 426978 - TAHI--DNSv6--some fields' value of the recieved packet is not consistent with the expected value
TAHI--DNSv6--some fields' value of the recieved packet is not consistent with...
Status: CLOSED DUPLICATE of bug 428639
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-12-29 02:31 EST by Zhiyong Wu
Modified: 2013-04-30 19:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 05:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-12-29 02:31:19 EST
Description of problem:

  When having DNSv6 tests in the server mode,we found that some fields' value of 

the recieved packet is not consistent with the expected value.

Version-Release number of selected component (if applicable):

  kernel-2.6.18-53.el5

Software Environment:   
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-53.el5 
   
  Tester(TN):   
    FreeBSD6.2
    v6eval-3.0.12.tar.gz
   
TAHI package:    
  DNS_Self_Test_1-1-1.tgz

How reproducible:
  every time

Steps to Reproduce:    
  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results 
  
Actual results:

   some fields' value of the recieved packet is not consistent with the expected
value.

Expected results:

   some fields' value of the recieved packet is consistent with the expected value.

Additional info:
  
   please refer to

   NUT is set to be the server mode

http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071220/DNS_Self_Test_1-1-1_server/index.html

   (1) 16	MX resource data

   (2) 17	NS resource data

   (3) 18	PTR resource data

   (4) 29	* class (the requestor is seeking data from more than one class)

   (5) 32	Name server acts in the role of a resolver

   (6) 35	The answer with CNAME to the query

   (7) 36	A name error indicating that the name does not exist

   (8) 48	Distribute zone

   (9) 132	ANCOUNT=0 and the answer section differs from the slave's local data

   (10)134	A slave ignores a NOTIFY request from a unknown master for the zone

   (11)143	Never merge RRs from response with RRs in cache

   (12)144	Update the TTL in cache with the TTL of the received answer

   (13)148	Server makes a judgment by the reliability of data (Data from the
authority section of an authoritative answer v.s. Data from the answer section
of a non-authoritative answer)

   (14)160	RRSet for PTR record

   (15)170	Negative answer should have an implicit referral built into the
answer (NXDOMAIN)

   (16)171	Negative answer should have an implicit referral built into the
answer (NODATA)

   (17)180	OPT pseudo-RR (recursive)

   (18)183	Responders don't understand OPT RR

   (19)202	PTR resource data

   NUT is set to be the client mode

http://focus.brisbane.redhat.com/~zwu/RHEL5.1-Server-20071017.0/20071220/DNS_Self_Test_1-1-1_client/index.html

   (1) 58	Caching several RRs of same type
Comment 1 RHEL Product and Program Management 2007-12-30 18:54:42 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Adam Tkac 2008-01-14 05:01:42 EST

*** This bug has been marked as a duplicate of 428639 ***

Note You need to log in before you can comment on or make changes to this bug.