Bug 426980 - Problem with system-config-network
Problem with system-config-network
Status: CLOSED DUPLICATE of bug 426766
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 02:43 EST by viswanathan
Modified: 2008-01-04 06:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 06:18:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description viswanathan 2007-12-29 02:43:59 EST
Description of problem:
I use fedora -8,
When I go to system-config-network ,I get the following bug Error

Version-Release number of selected component (if applicable):

This is the Error:
******************
Component: system-config-network
Version: 1.4.3
Summary: TB8a97ef57 NCHardwareList.py:692:load:ValueError: invalid literal for
int() with base 10: 'None'

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
277, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
289, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
780, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
692, in load
    hw.Modem.BaudRate = int(wvdial[dev]['Baud'])
ValueError: invalid literal for int() with base 10: 'None'

Local variables in innermost frame:
hwconf: <netconfpkg.NCHardwareList.ConfHWConf instance at 0xa49b88c>
i: 3
self: HardwareList.Ethernet.eth1.Status=ok
HardwareList.Ethernet.eth1.Name=eth1
HardwareList.Ethernet.eth1.Type=Ethernet
HardwareList.Ethernet.eth1.Card.ModuleName=usbnet
HardwareList.Ethernet.eth1.Description=Intel Corporation PRO/Wireless 3945ABG
Network Connection
HardwareList.Ethernet.eth0.Status=ok
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=r8169
HardwareList.Ethernet.eth0.Description=Realtek Semiconductor Co., Ltd. RTL8101E
PCI Express Fast Ethernet controller
HardwareList.Ethernet.eth2.Status=configured
HardwareList.Ethernet.eth2.Name=eth2
HardwareList.Ethernet.eth2.Type=Ethernet
HardwareList.Ethernet.eth2.Card.ModuleName=3c501
HardwareList.Ethernet.eth2.Description=3Com 3c501
HardwareList.Modem.Modem0.Status=configured
HardwareList.Modem.Modem0.Name=Modem0
HardwareList.Modem.Modem0.Modem.DeviceName=/dev/modem
HardwareList.Modem.Modem0.Type=Modem
HardwareList.Modem.Modem0.Description=Generic Modem

isdncard: <netconfpkg.NCisdnhardware.ConfISDN instance at 0xa6d1aec>
hw: Hardware.Status=configured
Hardware.Name=Modem0
Hardware.Modem.DeviceName=/dev/modem
Hardware.Type=Modem
Hardware.Description=Generic Modem

dev: Modem0
wvdial: <netconfpkg.conf.ConfSMB.ConfSMB instance at 0xa6d1b0c>



How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Lawrence 2007-12-29 11:28:38 EST
Reassigning to correct product/component so that the proper developer will see
this bug report.
Comment 2 Jiri Moskovcak 2008-01-04 06:18:50 EST

*** This bug has been marked as a duplicate of 426766 ***

Note You need to log in before you can comment on or make changes to this bug.