Bug 426988 - please bump avrdude to version 5.5
please bump avrdude to version 5.5
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: avrdude (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Trond Danielsen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 08:56 EST by Patrick C. F. Ernzer
Modified: 2008-02-06 02:36 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 02:35:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2007-12-29 08:56:31 EST
Description of problem:
Fedora 8 repos still have version 5.3.1 of avrdude, it would be nice if the
package maintainer could rebuild for the latest (5.5 as of today)

Version-Release number of selected component (if applicable):
avrdude-5.3.1-5.fc7

How reproducible:
always

Steps to Reproduce:
1. yum install avrdude
2. avrdude -c usbtiny -p t2313
  
Actual results:
no support for usbtiny (http://www.ladyada.net/make/usbtinyisp/index.html) in
the version served by Fedora repos

Expected results:
latest version please (simply because it had the usbtiny patches in, so it's
easier to point users to it.

Additional info:
oh, before you have to search, it seems avrdude is now at
http://www.nongnu.org/avrdude/
Comment 1 Alexei Podtelezhnikov 2007-12-29 13:58:46 EST
Please edit the bug title to reflect what you want to bump. it will be easier 
to query your bug report.
Comment 2 Trond Danielsen 2007-12-29 17:53:19 EST
New version coming up; should appear in koji within the next hour.
Comment 3 Trond Danielsen 2007-12-29 18:29:42 EST
https://admin.fedoraproject.org/updates/F8/pending/avrdude-5.5-1.fc8

New version available from updates-testing. Please provide feedback, and the
package will be pushed to stable on all branches within a few days.
Comment 4 Patrick C. F. Ernzer 2008-01-08 09:07:30 EST
in response to comment #3

  - URL         : http://www.bsdhome.com/avrdude/
    is still wrong, please adjust to http://www.nongnu.org/avrdude/

  - binary starts fine, as I do not have a programmer in this location, the
earliest I can test would be in a few weeks.

  - binary reports
$ avrdude -c help
[...]
  usbtiny  = USBtiny simple USB programmer,
http://www.ladyada.net/make/usbtinyisp/ [/etc/avrdude/avrdude.conf:382]
[...]
so at least at a cursory look it's OK.
Comment 6 rickyrockrat 2008-01-08 13:27:22 EST
AVR Dude 5.5 will need the patch I supplied for 64-bit systems:

Patch info URL
http://savannah.nongnu.org/patch/?6233
Patch itself
http://savannah.nongnu.org/patch/download.php?file_id=14754
Comment 7 Patrick C. F. Ernzer 2008-01-14 10:42:58 EST
reopening because of comment #5
Comment 8 Patrick C. F. Ernzer 2008-01-14 10:45:12 EST
doh! /me needs more coffee, obviously I reopened because of comment #6
Comment 9 Trond Danielsen 2008-01-15 01:52:19 EST
I have pushed a new version to rawhide that fixes both url and adds the 64-bit
patch. I will push it to updates-testing on both F7 and F8 when I get home from
work today.
Comment 10 Trond Danielsen 2008-02-06 02:35:23 EST
I pushed avrdude to stable on F7 and F8, therefore: Case closed.

Note You need to log in before you can comment on or make changes to this bug.