Bug 427019 - udevd[374]: nss_ldap: could not connect to any LDAP server as
udevd[374]: nss_ldap: could not connect to any LDAP server as
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev (Show other bugs)
5.0
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Harald Hoyer
https://bugs.launchpad.net/ubuntu/+so...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 20:46 EST by Ronald Chan
Modified: 2008-09-15 10:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 10:38:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ronald Chan 2007-12-29 20:46:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Description of problem:
When you try to configure your system to check authentication against an LDAP server, as soon as you restart your system on runlevel 3 udevd: can't contact an LDAP server although the server is fine.



Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.$ setup
2.$ choose LDAP authentication and enter a valid ldap server like dc=example,dc=com server 192.168.100.1 etc.
3. save configuration then restart your machine.

Actual Results:
udevd: is scheduling a retry to contact an LDAP server for an indefinite time, pressing CTRL-C will continue the next execution in daemon. but since udevd is failing some hardware doesn't work anymore.


Expected Results:
The server will continue to boot without an error

Additional info:
https://bugs.launchpad.net/ubuntu/+source/libnss-ldap/+bug/51315

visit this site for more details
Comment 1 Dax Bunce 2008-02-24 15:47:18 EST
This should be marked as critical, it affects Redhat 4 and 5.

If ldap is specified before files in the nsswitch.conf it will hang indefinitely
on boot in an attempt to contact an ldap server.

The bug is explained clearly on the Gentoo bugzilla site, authors of start_udev.
http://bugs.gentoo.org/show_bug.cgi?id=99564
Comment 2 Phil Knirsch 2008-04-28 08:30:33 EDT
Proposing for RHEL-5.3 and granting Devel ACK.

Read ya, Phil
Comment 3 RHEL Product and Program Management 2008-06-02 16:25:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Harald Hoyer 2008-09-02 10:40:05 EDT
udev should not need to contact an ldap server, as long as you don't have custom rules with users/groups which are not in the standard passwd/group file.
Comment 6 Dax Bunce 2008-09-02 16:45:07 EDT
No special configs in passwd/group files, just ldap before files in nsswitch.conf.
Eg:

passwd:    files ldap
shadow:    files ldap
group:     ldap files #<-This line in nsswitch.conf causes machine to hang on boot.

Not a problem if you know about it and real simple to fix, but it shouldn't try and do a ldap search before the network has been initialised and hang indefinitely if it doesn't respond.
Comment 7 Harald Hoyer 2008-09-03 08:18:30 EDT
not much udev itself can do about.
Comment 8 Harald Hoyer 2008-09-15 10:38:42 EDT
I am sorry, I can't fix that in udev.

Note You need to log in before you can comment on or make changes to this bug.