Bug 427020 - beagle package must require ndesk-dbus and ndesk-dbus-glib package
beagle package must require ndesk-dbus and ndesk-dbus-glib package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Nielsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 21:59 EST by sangu
Modified: 2008-03-13 11:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 11:23:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
beagled --fg --debug > d.txt 2>&1 (61.92 KB, text/plain)
2008-02-27 10:51 EST, Tomáš Bžatek
no flags Details

  None (edit)
Description sangu 2007-12-29 21:59:47 EST
Description of problem:
$ beagled --debug --fg
Always: Starting Beagle Daemon (version 0.3.2)
Always: Running on Mono 1.2.6
Always: Command Line: /usr/lib/beagle/BeagleDaemon.exe --debug --fg
Warn: Extended attributes are not supported on this filesystem. Performance will
suffer as a result.
Debug: Established a connection to the X server
Debug: Reniced process to 7
Debug: Done reading conf from /home/sangu/.beagle/config/Daemon.xml
Debug: Done reading conf from /etc/beagle/config-files/Daemon.xml
Debug: Starting messaging server
Debug: Done reading conf from /etc/beagle/config-files/Networking.xml
Warn: Inotify watches may be too low (8192) for some users!  Increase it to at
least 65535 by setting fs.inotify.max_user_watches in /etc/sysctl.conf
Debug: Starting QueryDriver
Debug: Found index helper at /usr/lib/beagle/beagled-index-helper
Debug: Found 2 backends in /usr/lib/beagle/Backends/EvolutionBackends.dll
Debug: Starting Inotify FSQ file event backend
Debug: Loaded 0 records from
/home/sangu/.beagle/Indexes/FileSystemIndex/FileAttributesStore.db in 0.000s
Debug: Done reading conf from /home/sangu/.beagle/config/FilesQueryable.xml
Debug: Done reading conf from /etc/beagle/config-files/FilesQueryable.xml
Debug: Checking if /home/sangu/Mail is kmail local mail directory ?
Warn: KMail backend: No index file for /home/sangu/Mail/drafts.Ignoring
/home/sangu/Mail, probably not a kmail directory.
Debug: KMail folders not found. Will keep trying 
Debug: KonqCacheDir: /var/tmp/kdecache-sangu/http
Debug: Found 20 backends in /usr/lib/beagle/BeagleDaemonLib.dll
Debug: Reading mapping from filters
Debug: Loading system static indexes.
Debug: Version mismatch in /var/cache/beagle/indexes/applications
Debug: Index has version 13.0, expected 18.-1
Warn: Unable to create read-only index (likely due to index version mismatch):
/var/cache/beagle/indexes/applications
Debug: Version mismatch in /var/cache/beagle/indexes/documentation
Debug: Index has version 13.0, expected 18.-1
Warn: Unable to create read-only index (likely due to index version mismatch):
/var/cache/beagle/indexes/documentation
Debug: Found 0 system-wide indexes.
Debug: Loading user-configured static indexes.
Debug: Found 0 user-configured static indexes..
Debug: Waiting 60 seconds before starting queryables

** (/usr/lib/beagle/BeagleDaemon.exe:3689): WARNING **: The following assembly
referenced from /usr/lib/beagle/BeagleDaemonLib.dll could not be loaded:
     Assembly:   NDesk.DBus.GLib    (assemblyref_index=9)
     Version:    1.0.0.0
     Public Key: f6716e4f9b2ed099
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib/beagle).


** (/usr/lib/beagle/BeagleDaemon.exe:3689): WARNING **: Could not load file or
assembly 'NDesk.DBus.GLib, Version=1.0.0.0, Culture=neutral,
PublicKeyToken=f6716e4f9b2ed099' or one of its dependencies.

** (/usr/lib/beagle/BeagleDaemon.exe:3689): WARNING **: Missing method Init in
assembly /usr/lib/beagle/BeagleDaemonLib.dll, type NDesk.DBus.BusG
Error: Unhandled exception thrown.  Exiting immediately.
System.IO.FileNotFoundException: Could not load file or assembly
'NDesk.DBus.GLib, Version=1.0.0.0, Culture=neutral,
PublicKeyToken=f6716e4f9b2ed099' or one of its dependencies.
File name: 'NDesk.DBus.GLib, Version=1.0.0.0, Culture=neutral,
PublicKeyToken=f6716e4f9b2ed099'
at Beagle.Daemon.BeagleDaemon.StartupProcess () <0x00171>
at IdleProxy.Handler () <0x00028>
at (wrapper native-to-managed) IdleProxy.Handler () <0x00040>
at (wrapper managed-to-native) GLib.MainLoop.g_main_loop_run (intptr) <0x00004>
at GLib.MainLoop.Run () <0x0000d>
at Beagle.Daemon.BeagleDaemon.DoMain (string[]) <0x00b71>
at Beagle.Daemon.BeagleDaemon.Main (string[]) <0x00014>


Unhandled Exception: System.NotSupportedException: Stream does not support writing
  at System.IO.FileStream.Write (System.Byte[] src, Int32 src_offset, Int32
count) [0x00000] 
  at System.IO.StreamWriter.FlushBytes () [0x00000] 
  at System.IO.StreamWriter.Decode () [0x00000] 
  at System.IO.StreamWriter.Flush () [0x00000] 
  at System.IO.StreamWriter.Write (System.String value) [0x00000] 
  at System.IO.CStreamWriter.Write (System.String val) [0x00000] 
  at System.IO.TextWriter.Write (System.Object value) [0x00000] 
  at Beagle.Util.Log.WriteLine (LogLevel level, System.String format,
System.Object[] args, System.Exception ex) [0x00000] 
  at Beagle.Util.Log.Warn (System.Exception ex, System.String message,
System.Object[] args) [0x00000] 
  at Beagle.Util.Logger.Warn (System.Exception ex, System.String message,
System.Object[] args) [0x00000] 
  at Beagle.Util.ExceptionHandlingThread.ThreadStarted () [0x00000] 
  at (wrapper delegate-invoke) System.MulticastDelegate:invoke_void ()

** (/usr/lib/beagle/BeagleDaemon.exe:3689): WARNING **: QueueUserAPC: error
looking up thread handle 0x40c


Version-Release number of selected component (if applicable):
0.3.2-1.fc9

How reproducible:
always

Steps to Reproduce:
1. $ beagled --debug --fg
2.
3.
  
Actual results:


Expected results:


Additional info:
ndesk-dbus-0.6.0-1.fc9
Comment 1 sangu 2007-12-29 22:11:28 EST
After installing ndesk-dbus-glib, beagle daemon works well.
beagle package doesn't require ndesk-dbus and ndesk-dbus-glib packages.

then
$ rpm -qR beagle | grep NDesk
mono(NDesk.DBus) = 1.0.0.0
mono(NDesk.DBus.GLib) = 1.0.0.0
Comment 2 Tomáš Bžatek 2008-02-27 10:49:38 EST
ndesk-dbus is still required:

** (/usr/lib/beagle/BeagleDaemon.exe:4176): WARNING **: The following assembly
referenced from /usr/lib/beagle/Util.dll could not be loaded:
     Assembly:   NDesk.DBus    (assemblyref_index=7)
     Version:    1.0.0.0
     Public Key: f6716e4f9b2ed099
The assembly was not found in the Global Assembly Cache, a path listed in the
MONO_PATH environment variable, or in the location of the executing assembly
(/usr/lib/beagle).

** (/usr/lib/beagle/BeagleDaemon.exe:4176): WARNING **: Could not load file or
assembly 'NDesk.DBus, Version=1.0.0.0, Culture=neutral,
PublicKeyToken=f6716e4f9b2ed099' or one of its dependencies.

...

After installing ndesk-dbus, everything works smoothly.

(the process beagled eventually ends with segfault)

libbeagle-python-0.3.0-4.fc9.i386
beagle-0.3.3-8.fc9.i386
beagle-gui-0.3.3-8.fc9.i386
beagle-devel-0.3.3-8.fc9.i386
libbeagle-0.3.0-4.fc9.i386
libbeagle-devel-0.3.0-4.fc9.i386
beagle-firefox-0.3.3-8.fc9.i386
ndesk-dbus-glib-0.4.1-3.fc9.i386
Comment 3 Tomáš Bžatek 2008-02-27 10:51:11 EST
Created attachment 296078 [details]
beagled --fg --debug > d.txt 2>&1
Comment 4 sangu 2008-03-13 11:23:36 EDT
$ rpm -e ndesk-dbus 
error: Failed dependencies:
[...]
	mono(NDesk.DBus) = 1.0.0.0 is needed by (installed) beagle-0.3.3-8.fc9.i386
$ rpm -e ndesk-dbus-glib
error: Failed dependencies:
[...]
	mono(NDesk.DBus) = 1.0.0.0 is needed by (installed) beagle-0.3.3-8.fc9.i386

Note You need to log in before you can comment on or make changes to this bug.