This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 427046 - Crashes on save
Crashes on save
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: blobAndConquer (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 12:09 EST by Kyrre Ness Sjøbæk
Modified: 2008-01-03 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 17:10:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config folder (135.02 KB, application/zip)
2008-01-01 10:21 EST, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2007-12-30 12:09:52 EST
Description of problem:
If you try to save game (or load the resulting save) after finishing the 2nd
objective in the first level (?), the game crashes.

Version-Release number of selected component (if applicable):
blobAndConquer-0.91-4.fc8

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hans de Goede 2007-12-31 09:01:37 EST
I just spend an hour trying to reproduce this without any luck. I assume that
with the first level you mean the level you get when you choose new game, and
with the second object you mean getting the info to exit through the caves?

Saving after that and restoring (either after quiting or directly) works fine.
Are you using a special arch like powerpc perhaps?

Anyways closing this as works for me for now. The only thing which could lead to
this actually getting fixed for you, would be to install
blobAndConquer-debuginfo, and then run blobAndConquer under gdb in windowed
mode, cause the crash and do a backtrace (bt command in gdb) after that.
Comment 2 Kyrre Ness Sjøbæk 2007-12-31 11:41:42 EST
No, no special arch, just plain i686 on an intel pentium 4 (3ghz), Nvidia
ElCheapo card and Nvidia driver. This is strange, as I have always been able to
reproduce it - but now I wasn't. I did a few things differently, tough:
- lower resolution (1024x768 instead of 1600x1200)
- Windowed mode (why?)
- Running directly instead of using wrapper
- Have installed debuginfo rpm
- Running through gdb

I can try to run it without windowed mode and with my old resolution. I can
also, if I manage to reproduce, send you the savegame (just loading it causes
crash). Where do I find those?
Comment 3 Hans de Goede 2007-12-31 11:50:34 EST
(In reply to comment #2)
> No, no special arch, just plain i686 on an intel pentium 4 (3ghz), Nvidia
> ElCheapo card and Nvidia driver. This is strange, as I have always been able to
> reproduce it - but now I wasn't. I did a few things differently, tough:
> - lower resolution (1024x768 instead of 1600x1200)
That might be the cause, I was using 800x600 (the default)

> - Windowed mode (why?)
Because if a fullscreen game segfaults while running under the debugger SDL's
segfault handler doesn't get called, and thus things effectively freeze (the
game is still fullscreen and still has the mouse and keyboard grabbed).

> - Running directly instead of using wrapper
Shouldn't make a difference

> - Have installed debuginfo rpm
Shouldn't make a difference

> - Running through gdb
Might make a difference, but I tried without gdb too.

> I can try to run it without windowed mode and with my old resolution. I can
> also, if I manage to reproduce, send you the savegame (just loading it causes
> crash). Where do I find those?

That might be an idea, just tar up and attach the contents of:
~/.parallelrealities/blobAndConquer
Comment 4 Kyrre Ness Sjøbæk 2008-01-01 10:21:54 EST
Created attachment 290611 [details]
Config folder
Comment 5 Kyrre Ness Sjøbæk 2008-01-01 10:23:50 EST
Reproced it. Loading the 2nd savegame crashes the game for me (it just "quits to
desktop", no freeze).

I have no GL desktop etc. enabled. Just thought that i should mention it.
Comment 6 Hans de Goede 2008-01-01 11:11:12 EST
Thanks, neither safe game works on my 64 bit machine, I'll take a look when I'm
behind a 32 bit machine and / or find the time to install a 32 bit Fedora on
this machine.
Comment 7 Kyrre Ness Sjøbæk 2008-01-01 12:36:26 EST
Perhaps change status then?

Strange that there should be a difference in savegames between 32- and 64- bit!
Is it some kind of mem dump?
Comment 8 Hans de Goede 2008-01-02 07:15:31 EST
Okay,

I've done some further digging into this, I think you will find that you can
reproduce your crash when saving to slot 2 or 3 no matetr how far you are in the
game, the other slots should work fine.

You probably already played blobAndConquer when it was still at version 0.90,
and they have changed the savegame format. They (upstream) explicitly reserves
the right to do that until blobAndConquer hits version 1.0 . 

I agree that crashing on this isn't pretty though. I'll try and see if I can fix
this.
Comment 9 Hans de Goede 2008-01-03 17:10:49 EST
I've given this some more thoughts and I've come to the conclusion that I
currently have other priorities then writing code to automatically remove the
old uncompatible save games, so I'm closing this.

Please let me know if you still have problems after doing
"rm -fr ~/.parallelrealities/blobAndConquer"


Note You need to log in before you can comment on or make changes to this bug.