Bug 427066 - incorrect selinux labels on files in /var/lib/texmf/tfm/jknappen/ec/
incorrect selinux labels on files in /var/lib/texmf/tfm/jknappen/ec/
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 15:15 EST by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.0-40.5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:06:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2007-12-30 15:15:24 EST
tetex's cronjob failed..

From: Anacron <root@gelk.kernelslacker.org>
Subject: Anacron job 'cron.daily' on gelk

/etc/cron.daily/tetex.cron:

error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecrm1200.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecti1000.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ectt1000.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecrm2488.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecbx1000.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecbx1200.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecrm0900.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecti0900.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecbx1440.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecbx2074.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecbx2488.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecrm1440.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecrm1000.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecrm2074.tfm: Permission
denied
error: failed to lstat /var/lib/texmf/tfm/jknappen/ec/ecbx0700.tfm: Permission
denied


The files it references are also not owned by any package.
Comment 1 Dave Jones 2007-12-30 15:17:54 EST
seems to be selinux related.

avc: denied { getattr } for comm=tmpwatch dev=md0
path=/var/lib/texmf/tfm/jknappen/ec/ecti1000.tfm pid=25521
scontext=system_u:system_r:tmpreaper_t:s0 tclass=file
tcontext=user_u:object_r:user_home_t:s0 

Somehow these are created as user_u:object_r:user_home_t instead of
system_u:object_r:tetex_data_t

restorecon fixes the labels.  But whatever creates these files needs fixing to
set them correctly in the first place (and also take ownership for the files so
that they get removed on package uninstall)
Comment 2 Daniel Walsh 2007-12-31 09:03:06 EST
Looks like these files are created in the postinstall section of the rpm and
then moved into place.   They should be restorecon -R -v in the postinstall script.
Comment 3 Jindrich Novy 2008-01-08 04:23:14 EST
I commited the restorecon run for /var/lib/texmf into F8 tetex, thanks Dan.
Comment 4 Fedora Update System 2008-01-24 17:01:52 EST
tetex-3.0-40.5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tetex'
Comment 5 Fedora Update System 2008-02-15 21:06:40 EST
tetex-3.0-44.6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tetex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1674
Comment 6 Fedora Update System 2008-02-15 21:06:47 EST
tetex-3.0-40.5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.